2

This question already has an answer here:

I'm using Ubuntu 15, and I'm trying to get Ubuntu 16. I was getting some 404 errors with sudo apt-get update, so I already looked into threads such as these

404 failed to fetch package https://stackoverflow.com/questions/30316812/ubuntu-apt-get-unable-to-fetch-packages

I resolved the errors by editing the /etc/apt/sources.list file so it looks like

###### Ubuntu Main Repos
deb-src http://old-releases.ubuntu.com/ubuntu/ wily main restricted universe multiverse 

###### Ubuntu Update Repos
deb http://old-releases.ubuntu.com/ubuntu/ wily-security main restricted universe multiverse 
deb http://old-releases.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse 
deb-src http://old-releases.ubuntu.com/ubuntu/ wily-security main restricted universe multiverse 
deb-src http://old-releases.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse 

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu wily partner
deb-src http://archive.canonical.com/ubuntu wily partner

###### Ubuntu Extras Repo
#deb http://extras.ubuntu.com/ubuntu wily main
#deb-src http://extras.ubuntu.com/ubuntu wily main

However, when I try sudo do-release-upgrade, I get 404 errors such as

...
Err http://old-releases.ubuntu.com wily-updates/restricted i386 Packages       
  404  Not Found                                                               
Err http://old-releases.ubuntu.com wily-updates/universe i386     Packages         
  404  Not Found                                                               
Err http://old-releases.ubuntu.com wily-updates/multiverse i386 Packages       
  404  Not Found 

...

Error authenticating some packages 

It was not possible to authenticate some packages. This may be a transient network problem. You may want to try again later. See below  for a list of unauthenticated packages. 

apt-xapian-index 
libboost-graph-parallel1.58.0 
libboost-mpi-python1.58.0 
libboost-mpi1.58.0 
virtualbox 
virtualbox-qt

how do I fix this?

marked as duplicate by Florian Diesch, Pilot6, Eric Carvalho, Zanna, Fabby Oct 17 '16 at 22:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Disable IPv6 in Network Settings. – TheWanderer Oct 17 '16 at 1:13
  • @zacharee, I just disabled IPv6 and tried sudo do-release-upgrade again, but I get the same 404 errors – user5739619 Oct 17 '16 at 3:25
  • @florian, this is not a duplicate. I already mentioned I changed archive to old-releases in /etc/apt/sources.list – user5739619 Oct 17 '16 at 3:28
  • Backup and install from scratch. – user589808 Oct 17 '16 at 8:45
1

If you look at old-releases.ubuntu.com you can see that Wily is not yet there.

http://old-releases.ubuntu.com/

You'll want to switch from old-releases to archive.ubuntu.com.

Not the answer you're looking for? Browse other questions tagged or ask your own question.