I recently switched from windows 10 to ubuntu 16.04 and been doing ok so far, one of my problems is that i have to go to system settings so switch the brightness of the screen, i have look up many solution but I'm not sure witch one is the simplest, hopefully someone can teach me a way to have a keyboard shortcut for this. I have an Asus Zenbook UX303L (not sure if matters).

I have tried editing in the grub GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to:

  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="
  • GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_osi='!Windows 2012'"
  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

To no success, actually this makes me unable to change the brightness through system settings.

  • acpi_osi= boot parameter should enable Fn+F5 and F6 keys. Also you may need to et brightness control to Intel. There is lots of guides. – Pilot6 Oct 16 '16 at 17:48
  • After you added acpi_osi= did you update grub? – Pilot6 Oct 17 '16 at 14:00
  • Yes I did, every time I changed it i would update the grub and restart the computer – pggodoy Oct 17 '16 at 14:11

This is unrelated to your GRUB issue, but it does solve your having to go into the settings to change the brightness problem.

I did a Google search related to your topic and found this page:


After installing this and testing it myself, less the keyboard feature, I can say it does work, minus a few quirks. (Scroll wheeling the icon messed the program up for me)

If you do not know how to install PPAs, you do it by opening up Settings, hitting Software & Updates, clicking Other Software, and clicking Add.

To install packages, you can either use apt-get or my preferred method, Synaptic.

| improve this answer | |
  • Thanks! I also looked at that solution but I would like to make it work as intended. In the meantime I'm using this solution askubuntu.com/questions/174770/… – pggodoy Oct 18 '16 at 14:16
  • I can't use the fn+F5/F6 combo but it works (trying to get use to the askubuntu format) – pggodoy Oct 18 '16 at 14:18

I was having the same problem with the brightness on my Gateway laptop (with integrated Intel graphics) and found this answer.

Instead of modifying the acpi_osi= value, what worked for me was to add acpi_backlight=vendor to the end of that command in "/etc/default/grub"

I had previously added acpi_osi=Linux to that line to solve the same issue in a previous version of Ubuntu (before upgrading to 16.04 LTS), so my full (working) line reads like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Of course, after editing that file, it's necessary to save the changes, then run sudo update-grub and restart.

After doing this, my keyboard shortcuts for brightness are working again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.