0

I can't get my second monitor to work. It's detected but black. A screenshot captures both desktops. They work fine in Windows. I want to span the desktop, I tried a 'new screen config' in Nvidia panel and then enabling Xinerama but it didn't do anything. I also couldn't find an option for TwinView. I can get the other (right) monitor working if I set that as default and switch monitors on/off but then left monitor is black.

Specs: i7 5820k, GTX 970, 32gb ram OS: Ubuntu 16.10 Driver: Nvidia 367.57 Monitors: Dell U2715H (1440p) x2 connected via DP daisy chain

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 367.57  (buildmeister@swio-display-x64-rhel04-13)  Mon Oct  3   21:41:11 PDT 2016

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.57  (buildmeister@swio-display-x64-rhel04-13)  Mon Oct  3 21:42:19 PDT 2016

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "Mouse0" "CorePointer"
   Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2715H"
    HorizSync       30.0 - 113.0
    VertRefresh     56.0 - 86.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2.8"
    Option         "metamodes" "DP-0.8: 2560x1440 +0+0, DP-0.1: 2560x1440 +2560+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

~            

screenshot

0

Best solution was this command: xset dpms force off

You run the command, screen goes to sleep/black, move your mouse and both monitors work. I added it to startup applications to make things easier.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.