0

I have Ubuntu 16.04, on a Lenovo Yoga 2 Pro. After a recent update, I restarted and several things went haywire, including the wireless and usb ports.
I am desperately trying to back up my home folder before fiddling with the internal guts of the OS just in case. But I can't make it acknowledge any USB drive. Funnily enough, it will recognize my Nexus 4 as a storage device when connected through a USB cable, but not a flash drive. Sadly, the Nexus 4 only has 2GB left of storage space, and I need about 10 GB, so I need it to recognize the USB.

The list of commands I have tried and their results:

  • lsusb: will see it, and by process of elimination (ie running that command, then plugging in the USB stick and running it again to see what changed), the USB stick is identified as such

    Bus 002 Device 106 : ID 1e3d:2096 Chipsbank Microelectronics Co., Ltd.
    
  • dmesg: shows when I plug it in. Example output:

    [numbers] usb 2-1 : new high-speed USB device number 106 using xhci_hcd
    [numbers] usb 2-1 : New USB device found, idVendor=1e3d, idProduct=095c
    [numbers] usb 2-1 : New USB device strings: Mfr=0, Product=0, SerialNumber=0
    

    And there is no disconnect message for usb 2-1. Note however, that one of the problems I think is that usb 2-7, which is the touchscreen, is constantly mounting and unmounting, so dmesg is flooded with messages from usb 2-7 and it just keeps going. I think the numbers are just a time stamp, so I didn't bother copying them all out, but if it's important the first one was 4318.991423, and they go up from there.

  • sudo fdisk -l: does not "see" the USB. As in, the command returns the same outputs before and after I plug in the USB.

    sudo blkid, lsblk are the same as the fdisk command; the same before and after I plug in the USB, so they are also not "seeing" it.

  • usb-devices: this does see it, and says it is on Bus 002. Which I guess we knew from above.

I'm sorry for not directly copy/pasting the outputs from these commands, but the laptop won't connect to any internet (wifi or ethernet as far as I can tell), so I'm typing it out manually, and so am taking slight shortcuts. If you want me to run commands and give the outputs, then please keep that in mind; I'll type the outputs out for you, but not if it's 100+ lines. Note that I've tried this with 5 different USBs, all with similar results.

Edit to add: The USB does not show up in the Disks application or the Files window (I checked under the Computer menu item in the left column as well as in the /media/ directory).

0

I never figured out what exactly was wrong, but I know it was a software issue; not only was the OS capable of recognizing the Nexus 4 android phone as a storage device (but no other USB flash drive), but when I booted up using a bootable USB with Ubuntu 14.04 LTS, it worked just fine. I was able to plug in and use a second USB to store my back up data after mounting the ssd in the usual manner through Nautilus. I had to use command line 'sudo -i' to be the root user before copying the folders, since my home folder was previously password-protected, but it all worked out in the end. A subsequent fresh install of Ubuntu has solved all of the original problems.

Moral of the story: whatever the problem was, it was fixed by a fresh install, preceded by backing up through a USB-bootable version of Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.