2

Im using Ubuntu 16.04.1
When I try to install some programs Im getting this error

Wine could not find a Gecko Package which is needed for applications embedding HTML to work properly. Wine can automatically download and install it for now.

When I click Install... It is trying to Download it... But at some point it is sticking always.

I also tried to install it from here https://wiki.winehq.org/Gecko I downloaded the .msi file But Wine is unable to install that msi file...

I also tried with

wine msiexec /i wine_gecko-2.47-x86_64.msi 

But getting this error -

fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:service:scmdatabase_autostart_services Auto-start service L"clr_optimization_v4.0.30319_32" failed to start: 1053
err:module:import_dll Library MSVCR100_CLR0400.dll (which is needed by L"C:\\windows\\Microsoft.NET\\Framework64\\v4.0.30319\\mscorsvw.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\Microsoft.NET\\Framework64\\v4.0.30319\\mscorsvw.exe" failed, status c0000135
err:service:service_send_command service protocol error - failed to write pipe!
fixme:service:scmdatabase_autostart_services Auto-start service L"clr_optimization_v4.0.30319_64" failed to start: 1053

I also Tried copying the file to /usr/share/wine/gecko But When I try to install the program It is again saying Wine could not find a Gecko Package...

What can I do?

  • Did you try running the msiexec command for both the x86_64 and x86 versions of the file. I understand that you do need both. – mchid Jun 22 '17 at 4:14
0

Wine Gecko comes "bundled" as part of their IE packages. Installing some flavour of IE should bring Gecko with it.

One of the apps I run under WINE uses .chm files a lot, and they weren't rendering (just blank). When I ran the file with wine hh file.chm in the terminal, this was the error message I got:

Could not load wine-gecko. ...

I used winetricks to install IE8 into my Wine space, and then the .chm files loaded perfectly -- error gone.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.