6

I was using Android Studio on my Ubuntu 14.04 64bit. That worked fine. Recently I installed Ubuntu 16.04 64bit, and I also installed Android Studio 2.2 on my PC. But my Android Studio crashes frequently. It closes instantly.

My java version:

java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Also I created $JAVA_HOME variable. I set right jdk location in my Studio. But it frequently crashes. Here with I have attached Studio error report.

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007ff6aba86384, pid=3955, tid=0x00007ff684e6d700
#
# JRE version: OpenJDK Runtime Environment (8.0_76-b03) (build 1.8.0_76-release-b03)
# Java VM: OpenJDK 64-Bit Server VM (25.76-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V  [libjvm.so+0x895384]  PhaseCCP::analyze()+0x274
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#

---------------  T H R E A D  ---------------

Current thread (0x00007ff6a40fa800):  JavaThread "C2 CompilerThread1" daemon [_thread_in_native, id=3968, stack(0x00007ff684d6d000,0x00007ff684e6e000)]

siginfo: si_signo: 11 (SIGSEGV), si_code: 128 (SI_KERNEL), si_addr: 0x0000000000000000...

I don't know why this problem occurs. Please help me to solve this issue.

  • Did you solve this problem ? I am facing the same issue now – Mithun Sarker Shuvro Jan 4 '17 at 12:07
  • 2
    No @MithunSarkerShuvro.. Still I am facing same problem.. I raised bug report in google issue list.. – Pechi Muthu Haridas Jan 5 '17 at 17:09
  • I am also facing same issue :( – Tirth Patel Jan 13 '17 at 17:31
  • @TirthPatel, I posted an answer. Check it once below. – Shashanth Jan 20 '17 at 6:18
0

as I see you're trying to run Android Studio using Java SE. PLease install Oracle Java 8 Java Development Kit (JDK) and set it in Android Studio using File_>Project Structure.

| improve this answer | |
  • Hi Piotrek1543! I think I already installed Java jdk before installing Android Studio using this command. $ sudo add-apt-repository ppa:webupd8team/java $ sudo apt-get update $ sudo apt-get install oracle-java8-installer. If something missing, then how to I install Java 8 JDK? – Pechi Muthu Haridas Oct 28 '16 at 9:19
0

I also faced the same problem in my Ubuntu 16.04, with Android Studio 2.2.3 installed. What I did is a simple trick.

Goto your home directory.

home/<your_name>

And hit Ctrl + H . Now this will display the hidden directories inside your home directory. Find out .android [dot android] and delete it. You can keep backup and then delete the directory.

This process remove the old cache of Android Studio. Now start your Android Studio, the IDE automatically creates .android directory.

| improve this answer | |
0

You did not include the entire Studio crash log file. But if your log contains something that looks similiar to: Stack: [0x00007ff49571f000,0x00007ff495820000], sp=0x00007ff49581ca00, free space=1014k Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code) C [libX11.so.6+0x4a949] XSetICValues+0xf9 j sun.awt.X11.XInputMethod.setXICFocusNative(JZZ)V+0 j sun.awt.X11.XInputMethod.setXICFocus(Ljava/awt/peer/ComponentPeer;ZZ)V+25 j sun.awt.X11InputMethod.activate()V+162 j sun.awt.im.InputContext.activateInputMethod(Z)V+169 j sun.awt.im.InputContext.focusGained(Ljava/awt/Component;)V+137 J 45972 C2 sun.awt.im.InputMethodContext.dispatchEvent(Ljava/awt/AWTEvent;)V (62 bytes) @ 0x00007ff502eabc48 [0x00007ff502eab8e0+0x368] J 72758 C1 java.awt.Component.dispatchEventImpl(Ljava/awt/AWTEvent;)V (883 bytes) @ 0x00007ff50746da94 [0x00007ff50746a4e0+0x35b4] J 21802 C2 java.awt.Container.dispatchEventImpl(Ljava/awt/AWTEvent;)V (129 bytes) @ 0x00007ff4ff1e6934 [0x00007ff4ff1e68e0+0x54] J 40400 C1 java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Ljava/awt/Component;Ljava/awt/AWTEvent;)Z (352 bytes) @ 0x00007ff5020f87dc [0x00007ff5020f6820+0x1fbc] J 72166 C2 java.awt.DefaultKeyboardFocusManager.dispatchEvent(Ljava/awt/AWTEvent;)Z (1589 bytes) @ 0x00007ff503c34a68 [0x00007ff503c325e0+0x2488]

Then you are most likely having issues due to known, long standing bug with AS (and IntelliJ) and iBus as documented here by Google.

As per that page, what I found works best for me is:

Workaround #2: Disable IBus input in Studio

$ XMODIFIERS= ./bin/studio.sh

| improve this answer | |
  • Hi! Where I find Android Studio crash log files, you have mentioned it. Please comment. – Pechi Muthu Haridas Mar 3 '18 at 8:48
  • The crash log files are in your home folder usually. – Maks Mar 3 '18 at 8:51
  • Still I am facing this issue. This is my log files drive.google.com/drive/folders/…. Please help me to fix Android Studio issues. – Pechi Muthu Haridas Mar 3 '18 at 9:07
  • Sorry all I can say is what worked for me based on the recommendation in the Android Studio documentation. – Maks Mar 3 '18 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.