0

I have a 64-bit MacBook Pro (Intel Core i5) running OS X version 10.8.4 (Mountain Lion), and want to install Ubuntu 16.04.1 (Xenial Xerus) on an existing empty partition of my external hard drive. This apparently requires creating a bootable DVD, CD, or USB flash drive, so I’m trying to create a bootable DVD-R. Unfortunately, when I download the disk image, open Disk Utility, select File → Open Disk Image..., choose the correct image file, and click Open, I get an error message, "Unable to attach "ubuntu-16.04.1-desktop-amd64.iso." (no mountable file systems)".

There are several existing pages on askubuntu.com that address issues like this, but most of them are at least 4 years old and appear no longer relevant. For example, How do I get my Mac to boot from an Ubuntu USB key? suggests using a Mac-specific ISO (amd64+mac), but I can’t find a mac-specific ISO of Xenial.

Thanks in advance for your help!


I was going to include here the URLs for several pages I've already looked at that didn't solve the problem (mostly on ubuntu.com and askubuntu.com), but unfortunately since this is my first post, my reputation is zero and I'm limited to two URLs. I used one of those URLs above. The other is http://forums.macrumors.com/threads/dd-usb-to-partition.1329407/ ; it has instructions like "+Use UNetbootin to install the files to the root drive (usb)", which are too vague/unfamiliar for me.

Another web page suggested hdiutil attach -verbose -noverify -nomount downloaded_ubuntu.iso. I did in fact open Terminal and enter that string, but I got errors like CBSDBackingStore::newProbe stat() failed. No such file or directory.


Update after one comment from muru and two comments from CelticWarrior:

Thanks very much for pointing out some silly mistakes I made. (There were reasons! I swear there were reasons!) Unfortunately, correcting the mistakes didn’t solve the problem.

muru: I tried replacing “downloaded_ubuntu.iso” with the full path and file name when following the advice at Why can't I mount the Ubuntu 12.04 installer ISOs in Mac OS X?

CelticWarrior: I tried burning the DVD from the Finder instead of from Disk Utility. Also, I found https://help.ubuntu.com/community/BurningIsoHowto , which had slightly different Disk Utility instructions than what I’d been doing, and tried those as well.

But I keep getting results like:

o The DVD burns and verifies successfully, but the ISO file doesn’t get unpacked, only copied. So the DVD contains one file in ISO format.

o The DVD seems to burn and verify successfully, but then I get the error, "The disk you inserted was not readable by this computer."

o Before I get to the stage of burning the DVD, I get the error, "Unable to attach "ubuntu-16.04.1-desktop-amd64.iso." (no mountable file systems)"

It’s not trivial if I can't get it to work! :-P

Thank you for helping me with this.

  • You did change downloaded_ubuntu.iso to the name of the ISO you downloaded, right? – muru Oct 16 '16 at 7:10
  • Burning a DVD from an image file (ISO) is trivial in any OS provided you have decent burning software and you certainly have it on MacOS: ubuntu.com/download/desktop/burn-a-dvd-on-mac-osx – user589808 Oct 16 '16 at 7:36
  • Creating a USB live installer is also trivial: ubuntu.com/download/desktop/create-a-usb-stick-on-mac-osx – user589808 Oct 16 '16 at 7:37
  • I've added an update to the original post (starts with a horizontal line and the word "Update"). – Rendbanana Oct 16 '16 at 17:10
  • I found a video youtube.com/watch?v=ld7UVefOvHo which provides a specific Terminal command to extract the ISO. I changed the device name and file name: dd if=/dev/disk3s2 of=./ubuntu-16.04.1-desktop-amd64-extracted.iso bs=1m Unfortunately this still didn't work. In the video, the new "extracted" file was the same size as the original ISO; but when I tried it, the original ISO was 1.51 GB while the extracted copy was 2.4 GB. The video also suggests burning to a CD instead of a DVD, but Ubuntu has gotten large enough that that's apparently no longer possible. – Rendbanana Oct 17 '16 at 5:07
1

With help from a friend, I was able to create an install disk. Here are the steps we took after downloading the ISO:

  1. Used Toast to convert the ISO to DMG.
  2. Opened Disk Utility.
  3. Dragged the DMG file from the Finder to Disk Utility.
  4. Used Disk Utility to burn the DMG to a new disk (DVD-R), by selecting the DMG file and clicking “Burn”.

In retrospect, it seems likely that one of my prior attempts was actually successful but that I couldn’t tell it was successful. Notice how one of the results I listed was that the DVD seemed to burn and verify successfully, but then I got the error, "The disk you inserted was not readable by this computer”? I’m guessing that was because my Mac (OS X version 10.8.4) couldn’t read the file system used in the ISO, and that if I’d tried to use that disc it have worked.

  • So were you able to create the Ubuntu dvd for mac ? – George Udosen Dec 28 '16 at 6:04
  • Isn’t Toast able to burn the ISO directly? – Melebius May 16 '17 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.