0

I installed XAMPP on Ubuntu 16.04.1 through these instructions. Problems are:

  1. Can't access localhost/phpmyadmin.

    Please click this image.

  2. MySQL Database won't run.

  3. When I open Configure > Open Log from MySQL Database XAMPP GUI. Here is the result.

    2016-10-16 09:54:30 8005 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql 
    2016-10-16  9:54:31 139780487444288 [Note] Using unique option prefix 'key_buffer' is error-prone and can break in the future. Please use the full name 'key_buffer_size' instead. 
    2016-10-16  9:54:31 139780487444288 [Note] /opt/lampp/sbin/mysqld (mysqld 10.1.16-MariaDB) starting as process 8152 ... 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: innodb_empty_free_list_algorithm has been changed to legacy because of small buffer pool size. In order to use backoff, increase buffer pool at least up to 20MB.
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Using mutexes to ref count buffer pool pages 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: The InnoDB memory heap is disabled 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Memory barrier is not used 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Compressed tables use zlib 1.2.8 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Using generic crc32 instructions 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Initializing buffer pool, size = 16.0M 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Completed initialization of buffer pool 
    2016-10-16  9:54:31 139780487444288 [Note] InnoDB: Highest supported file format is Barracuda. 
    2016-10-16  9:54:32 139780487444288 [Note] InnoDB: 128 rollback segment(s) are active. 
    2016-10-16  9:54:32 139780487444288 [Note] InnoDB: Waiting for purge to start 
    2016-10-16  9:54:32 139780487444288 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.30-76.3 started; log sequence number 1762733 
    2016-10-16  9:54:32 139780096513792 [Note] InnoDB: Dumping buffer pool(s) not yet started 
    2016-10-16  9:54:32 139780487444288 [Note] Plugin 'FEEDBACK' is disabled. 
    2016-10-16  9:54:32 139780487444288 [Note] Server socket created on IP: '::'. 
    2016-10-16  9:54:32 139780487444288 [ERROR] Can't start server: Bind on TCP/IP port. Got error: 98: Address already in use 
    2016-10-16  9:54:32 139780487444288 [ERROR] Do you already have another mysqld server running on port: 3306 ? 
    2016-10-16  9:54:32 139780487444288 [ERROR] Aborting
    2016-10-16 09:54:34 8005 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/laptop.pid ended 
    2016-10-16 10:04:30 9155 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql 
    2016-10-16 10:04:30 140396037838656 [Note] Using unique option prefix 'key_buffer' is error-prone and can break in the future. Please use the full name 'key_buffer_size' instead. 
    2016-10-16 10:04:30 140396037838656 [Note] /opt/lampp/sbin/mysqld (mysqld 10.1.16-MariaDB) starting as process 9299 ... 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: innodb_empty_free_list_algorithm has been changed to legacy because of small buffer pool size. In order to use backoff, increase buffer pool at least up to 20MB.
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Using mutexes to ref count buffer pool pages 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: The InnoDB memory heap is disabled 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Memory barrier is not used 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Compressed tables use zlib 1.2.8 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Using generic crc32 instructions 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Initializing buffer pool, size = 16.0M 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Completed initialization of buffer pool 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Highest supported file format is Barracuda. 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: 128 rollback segment(s) are active. 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB: Waiting for purge to start 
    2016-10-16 10:04:30 140396037838656 [Note] InnoDB:  Percona XtraDB (http://www dot percona dot com) 5.6.30-76.3 started; log sequence number 1762743 
    2016-10-16 10:04:30 140395652552448 [Note] InnoDB: Dumping buffer pool(s) not yet started 
    2016-10-16 10:04:30 140396037838656 [Note] Plugin 'FEEDBACK' is disabled. 
    2016-10-16 10:04:30 140396037838656 [Note] Server socket created on IP: '::'. 
    2016-10-16 10:04:30 140396037838656 [ERROR] Can't start server: Bind on TCP/IP port. Got error: 98: Address already in use 
    2016-10-16 10:04:30 140396037838656 [ERROR] Do you already have another mysqld server running on port: 3306 ? 
    2016-10-16 10:04:30 140396037838656 [ERROR] Aborting
    2016-10-16 10:04:32 9155 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/laptop.pid ended
    

Anyone can help me with this?

UPDATE

Although in XAMPP GUI mysql does not work, when I run it at terminal it works. So I don't know which one should I believed in.

$ sudo /opt/lampp/xampp start
Starting XAMPP for Linux 7.0.9-1...
XAMPP: Starting Apache...already running. 
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.

Reinstalled XAMPP:

MySQL Database is Running, Apache Web Server Stopped.

Starting XAMPP for Linux 7.0.9-1...    
XAMPP: Starting Apache...fail.    
XAMPP:  Another web server is already running.    
XAMPP: Starting MySQL...already running.    
XAMPP: Starting ProFTPD...fail.    
XAMPP:  Another FTP daemon is already running.
1

I had this problem once when i was using Linux mint 19, i did some google search about it, but never really understood what is the cause of this problem, even after i knew the solution.

After some time, i noticed that there is something called Unit mysql.service conflicting with my own MySQL database.

How to solve it?

I can notice that you are running Ubuntu, so the installation directories of XAMPP, MySQL... should be the same as elaborated below:

  • Install XAMPP correctly.
  • Open terminal and Type the command sudo /opt/lampp/lampp start to run the XAMPP services.
  • Open up a new terminal window, then type this command: sudo service mysql stop.
  • Restart the XAMPP services: sudo /opt/lampp/lampp restart.

Now you can access phpMyAdmin via browser, and your database monitor via Terminal.

Please Note: This solution does NOT fix the problem permanently! It only let you work in your databases as far as you logged in your session, after you restart, you have to do the same steps above.

-1

step 1: open file /opt/lampp/etc/my.cnf
step 2: add code innodb_force_recovery = 1
step 3: restart or start MySql.

  • From the error messages, it doesn't look like googol8080's database has crashed, so triggering a recovery action on it should be unnecessary. – n.st Oct 21 '16 at 3:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.