Since I upgraded Ubuntu 16.04 to 16.10 DNS resolution stopped working every time the computer wakes up from standby. Pinging IP addresses directly works without a problem. So the issue seems to be DNS related. To solve it I have to reboot the computer (logout and login doesn't solve it).

Any idea how to investigate this issue further?

  • Same here. For me, DNS resolution doesn't work at all (i.e. also not after booting), whereas ping to works fine. The DNS shown under "Connection Information" is the same as the one shown on another computer where the connection through the same modem works fine.
    – Stefan
    Oct 16 '16 at 7:48
  • Same here. I joined bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1618839 though it was reported for xenial
    – bentolor
    Nov 6 '16 at 7:54

I've had the same issue with Ubuntu 16.10 on MacbookPro.

Fixed it by disabling dnsmasq in network manager by commenting out dns=dnsmasq in /etc/NetworkManager/NetworkManager.conf.

  • 2
    This fixed my issue on 16.04. I only recently saw the issue on 16.04, whereas the intial bulk of reports came in around October for 16.10, so perhaps 16.04 just received the same buggy update to network manager or dnsmasq. Here's the Ubuntu bug with some discussion.
    – BeeOnRope
    Mar 12 '17 at 18:32

What I've found is this thread where users are complaining for dnsmasq and advising to restart it. I've tried (sudo service dnsmasq restart) and it helped. So I configured this restarting to cron job every minute as temporary solution.

  • I don't have dnsmasq installed so that this solution doesn't work for me.
    – jans
    Oct 20 '16 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.