7

When I run sudo apt-get update, this is what shows up:

hit1,hi2,3.. blah blah blah then this

N: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension

Need help as soon as possible This is happening to me after I upgraded to Ubuntu 16.10 from 16.04!

11

This is not a severe problem. It simply says that the file in /etc/apt/apt.conf.d/20auto-upgrades.ucf-dist is ignored because of invalid file extension. Remove the extension and it should be all OK.

sudo mv /etc/apt/apt.conf.d/20auto-upgrades.ucf-dist /etc/apt/apt.conf.d/20auto-upgrades

is the command you'll run to rename it.

In my 16.04, the content of the file is some configuration options related to apt that control whether or not automatic package update will run and automatic cleaning of packages will occur. Here is the content of it

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Periodic::Unattended-Upgrade "0";
| improve this answer | |
  • @NaiemdaLegend Has your problem got fixed? – Anwar Oct 15 '16 at 15:29
  • @NaiemdaLegend Glad to hear. You can also accept the answer. That works as "Thanks" :) – Anwar Oct 15 '16 at 17:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.