While using VirtualBox, I am getting the error shown in the picture. I executed the command suggested, but still I am getting the error.

enter image description here

  • 2
    Welcome to AskUbuntu. If you write out the error message it will be easier for you to find a resolution. The system will even give suggestions where the same errors has been resolved by others. You loose this potential by using pictures rather than text. Also the images takes up a lot of unnecessary space on the server. Try to user images when text won't suffice. In this case the specific text error is clear. Oct 15, 2016 at 12:02
  • Most dialogue windows in Linux let you select, copy and paste their text content by the way. Oct 15, 2016 at 22:05
  • 1
    These instructions work for Ubuntu 17.10: sudo apt-get autoremove sudo /sbin/vboxconfig from this post on VirtualBox Forums Apr 16, 2018 at 9:38

4 Answers 4


The image in the picture is giving you this error message: rtr3initex failed with rc=-1912 (rc=-1912) Ubuntu

It's telling you you have a mismatched install. Your kernel modules do not match your installed version. The kernel modules are packaged in virtualbox-dkms in the repository.

You have most likely installed it from the repository. But failed to install all the modules, or you installed it, performed and upgrade and the modules didn't get completely upgraded during one of your system's updates. You can fix this by uninstalling it and reinstalling it, which will install the necessary modules. You do this with:

$ sudo apt remove --purge virtualbox
$ sudo apt install virtualbox
$ sudo apt install virtualbox-dkms

Completely removing virtualbox and it's dependencies will not affect your VM's. Just the applicaton itself.

Alternatively you can download the latest version of Virtualbox from http://Virtualbox.org. The download page for linux is: https://www.virtualbox.org/wiki/Linux_Downloads.

You can append this to your /etc/apt/sources.list file to add the official developers repository:

deb http://download.virtualbox.org/virtualbox/debian xenial contrib

You can download and add the security key with:

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

Then grade what you currently have with:

$ sudo apt update
$ sudo apt upgrade

If you purged the previous version then reinstall it with this after the upgrade command above:

$ sudo apt install virtualbox

If you download and install from virtualbox.org the kernel modules for the developers version will automatically be compiled and installed.

  • 1
    Hello. I had VirtualBox 5.0.4 which freezes my system (I have Kernel 4.13.xx). Then I purged as you wrote above and installed using Virtual Box site. Yet I still get this message. What should I do?
    – Royi
    Mar 16, 2018 at 7:09
  • 2
    @Royi I take it that you are saying the error is the exact message. Run these commands: (1) sudo apt remove --purge virtualbox-dkms ; (2) virtualbox-dkms . You may have to run this afterward: /sbin/rcvboxdrv setup Mar 16, 2018 at 12:48
  • I ran #1, but now #2 says doria@doria:/home/doria$ virtualbox-dkms virtualbox-dkms: command not found Jan 17, 2019 at 19:40
  • @L.D.James You don't need to run virtualbox-dkms (you removed it, no?). Anyway it works. Mar 10, 2019 at 0:54


sudo apt-get autoremove
sudo /sbin/vboxconfig
  • 4
    Welcome to Ask Ubuntu! Could you edit your answer to explain how this should help?
    – Melebius
    Sep 18, 2019 at 9:50
  • This helped actually in my case. Thank you :)
    – Vadim
    May 2, 2020 at 14:45
  • Worked for me! Ubuntu 18.04 host running Windows10 Guest.
    – Joel
    Aug 4, 2020 at 14:53

I see this is an old question, but I just had this problem and, while the answers already listed here may well be correct and solve the problem, they aren't actually necessary and theres a much easier way to fix it.

If Virtualbox has previously been installed and was working, then this problem can arise after a system update, as it did with me. It seems that VB is updated, but the dkms is not.

In order to obtain the correct dkms, it's necessary to also perform an 'upgrade'.

You can check if this is the case by running:

apt list --upgradable

and the dkms package will likely be shown as an available upgrade.

If so, simply run:

sudo apt upgrade

and the problem will be fixed.


From L. D. James's comment:

sudo apt purge virtualbox-dkms
sudo /sbin/rcvboxdrv setup

I've done this after a virtualbox downgrade and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .