0

My Ubuntu doesn't want to install TeamViewer 11 again. :(
I had problems with sound - I tried to install Realtek HD Audio driver, but Ubuntu after installation and reboot forgot about sound chip on my motherboard and no sound was produced.
So I decided to reinstall Ubuntu (with saving my personal data including apps) using my USB Key.
Well - I had to install again GRUB Customizer, Steam and more recent apps that I use and they worked perfectly.
Without TeamViewer... TeamViewer dropped some problems with packages not installed, but after, when I wrote to terminal commend

sudo apt-get install -f

it installs these packages, uninstalling also TeamViewer.
Now when I try to install 32bit version, terminal dropps me this error:

Selecting previously unselected package teamviewer:i386.
(Reading database ... 179972 files and directories currently installed.)
Preparing to unpack .../teamviewer_11.0.67687_i386.deb ...
Unpacking teamviewer:i386 (11.0.67687) ...
dpkg: dependency problems prevent configuration of teamviewer:i386:
teamviewer:i386 depends on libpng12-0.

dpkg: error processing package teamviewer:i386 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer:i386

On 64bit version I see this error:

Selecting previously unselected package teamviewer.
(Reading database ... 179972 files and directories currently installed.)
Preparing to unpack .../teamviewer_11.0.67687_amd64.deb ...
Unpacking teamviewer (11.0.67687) ...
dpkg: dependency problems prevent configuration of teamviewer:
teamviewer depends on lib32asound2; however:
  Package lib32asound2 is not installed.
  teamviewer depends on ia32-libs; however:
  Package ia32-libs is not installed.

 dpkg: error processing package teamviewer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer

So... what can I do? On Ubuntu 16.04.1 LTS worked fine.

I used this tutorial.

2
  • I don't think TeamViewer supports 16.10 yet. Oct 15 '16 at 12:34
  • I thought so... But I found solution. Oct 16 '16 at 11:09
2

I have the solution for installing TeamViewer on 16.10. I hope that this will work for all.
When you see this error...

Selecting previously unselected package teamviewer:i386.
(Reading database ... 179972 files and directories currently installed.)
Preparing to unpack .../teamviewer_11.0.67687_i386.deb ...
Unpacking teamviewer:i386 (11.0.67687) ...
dpkg: dependency problems prevent configuration of teamviewer:i386:
 teamviewer:i386 depends on libpng12-0.

dpkg: error processing package teamviewer:i386 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer:i386

type sudo apt-get install -f and say "yes".
After that go to this website, download the package and install also from terminal using command

sudo dpkg -i libpng12-0_xxxxx_i386.deb

where xxxxx is the version of your libpng. I used the stable version 1.2.50-2+deb8u2.
After that again install TeamViewer and you will don't have errors. ;)
I hope that for everyone this solution will work perfectly.

2

Use new Teamviewer 12, it doesn't have libpng12 dependency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.