0

I have a Ubuntu server 16.04 installation and I'm trying to get rid of the message of the day.

I've already disabled all the files in /etc/update-motd.d/ and run-parts /etc/update-motd.d/ Doesnt't output anything.

In addition to that I've commented out the motd lines in those 2 files:

/etc/pam.d/login
/etc/pam.d/sshd

The problem is that I'm still getting system information printed whenever I login over ssh.

Does anyone know where this could be coming from?

0

After some poking around in the sshd_config file, I found the Banner option and that referenced the file /etc/issue. Said file contained exactly the message I was seeing on each ssh login. I've commented out the Banner option and that fixed the issue. Hope that helps someone in the future.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.