0

I've installed ubuntu gnome and it won't let me run the grub2 boot loader from my hard drive when I start the computer and then would try to start using a lan network and would restart the boot process again. I burned disk with grub2 using http://www.supergrubdisk.org/super-grub2-disk/

If I boot off of that disk I can select ubuntu and boot it but I can't boot without this disk because the default grub2 boot loader will not start on boot.

I'd like to be able to boot my computer without this disk.

pastebin link: http://paste2.org/jJHJ0sB9

  • Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith Oct 15 '16 at 14:24
  • You might try turning UEFI Secure boot off in UEFI. But make sure you are booting in UEFI boot mode, not BIOS/CSM/Legacy mode. You somehow installed a grub BIOS boot loader to gpt's protective MBR, but it will never work. Just do not boot in BIOS mode and the incorrect grub will never be seen. – oldfred Oct 15 '16 at 20:56
  • how do i do that, im looking it up not but i cannot find a simple explanation. – 3rdParty Oct 16 '16 at 1:32
  • plus i no longer have windows installed so i can't edit the UEFI from there – 3rdParty Oct 16 '16 at 1:35
  • i tried to run systemctl reboot --firmware-setup and it gave me this error: "Cannot indicate to EFI to boot into setup mode: No such file or directory" – 3rdParty Oct 16 '16 at 1:42
1

I fixed this by reinstalling grub2 from boot repair. First it gave me an error saying

Failed to open /EFI/BOOT/grubx64.efi - Not Found 

I then realised I could go into the foler /boot/efi/EFI/ubuntu/ to find the GRUB file where it had been reinstalled and then copy /boot/efi/EFI/ubuntu/shimx64.efi, /boot/efi/EFI/ubuntu/grubx64.efi and /boot/efi/EFI/ubuntu/grub.cfg to the folder it said it could not find the files in which was /boot/efi/EFI/BOOT/

After I did that my computer will now correctly boot GRUB when booting from the HDD.

0

Make a bootable USB of Ubuntu, boot from it then. Use the commands given in this link Repair/Reinstall/Restore Grub

  • my laptop will not let me boot from usb, it is an option in the bios but not in the multi boot menu and will not boot at all – 3rdParty Oct 15 '16 at 7:19
  • this is the pastebin link for my boot paste2.org/jJHJ0sB9 – 3rdParty Oct 15 '16 at 7:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.