1

I have Ubuntu 16.04 in hp laptop. Few days before my unity launcher and everything disappeared. I have the second account on this PC on which Unity is working perfectly fine. I have tried links such as:

I can use ccsm and it is showing me every option required. And even though I enable Unity plugin and every other option comes for enabling it, but even after the reboot, I can't get my Unity back, and again if I launch ccsm then I can see Unity plugin is unselected. What should I do?

  • You did link to 15 pages of information, but I can't tell by those pages what you actually did. Can you add some actual text to your question indicating some of what you have tried that failed. Then I'll use the 15 pages that you lined to to try to see what you missed that might work. Otherwise, I might start over asking you to test a lot of things that you have already done. The first thing that come to might might be the obvious, but I hesitate to suggest it without any of it actually typed out in your question. – L. D. James Oct 14 '16 at 13:57
  • on this link, I have tried the accepted answer. and this - export DISPLAY=:0 sudo dconf reset -f /org/compiz/ and then setsid unity – Brij Raj Kishore Oct 14 '16 at 14:00
  • You can only accept an answer to a question that you asked. You can up-vote any question, answer, or comment that you think is useful and have value to you and the community. Are you saying your issue is resolved? – L. D. James Oct 14 '16 at 14:03
  • No, I mean that on the first link there is an answer with green mark having 385 upvote and I have tried it already but didn't get a positive result – Brij Raj Kishore Oct 14 '16 at 14:05
  • What is the output you get when running find ~/ ! -user $(whoami)? You can hit ALT+Cntrl+F2 to get to a command prompt to type in the command from your account. – L. D. James Oct 14 '16 at 14:09
2

Your CCSM configuration isn't sticking because you don't have ownership (permission) of key configuration files and folders in your home directory. You can verify this with:

$ find ~/ ! -user $(whoami)

To regain ownership of files in your home folder you can run this command:

$ sudo chown -R $(whoami):$(whoami) ~/

That should be sufficient for loading the desktop successfully. The CCSM configuration you mention in your question would then stick between reboots.

This issue is created by running certain GUI applications as sudo.

Update:

The resolution was to rename the ~user folder and create a clean one. Then copy the files from the old ~user folder.

The steps need to be performed a different account). Create an account B. Login as B. To perform the steps. The B needs to have sudo access. This can be done with. Consider A your account and B the different account to perform the commands.

$ sudo adduser B sudo

From the terminal (of B login) run:

$ cd ~A
$ cd ..
$ sudo mv A A.str
$ sudo mkdir A
$ sudo chown A:A A
$ sudo ln -s A.str ~A/A.str

Now login as A and copy or move your content from a folder A.str in your fresh login.

  • $ find ~/ ! -user $(whoami) is giving me nothing now – Brij Raj Kishore Oct 14 '16 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.