13

I have a Dell precision tower 3620 desktop, with Ubuntu 16.04 installed.

I have recently (today) updated it(not upgraded), and afterwards it asked for a reboot, so I did that. However, after reboot it showed the login screen and mentioned connection established (for internet through Ethernet), and login password cursor was blinking during that time but after that even the cursor stopped blinking and accepting no response from keyboard or mouse. Only one option is to force shutdown. I have no idea what part of the update resulted in this.

Everything was working fine before the update. Once the Ethernet icon announcing connection has been established goes away, it takes away the blinking of the cursor, then keyboard and mouse simply won't work. I even tried connecting keyboard on other slots, but no success. Can I uninstall the last update?

NOTE:

I heard a sound from the processor when login screen comes and in between the cursor also blinks, but once this sound is over then the blinking freezes and you have to forcibly shutdown, as this is an institute computer (I took the admin privilege, headache). Now I am really worried about it. How to fix it?

IMPROVEMENT

I did not have to go for a live USB, and I was able to go to grub
I was able to go to the GRUB menu by pressing the Esc key). This what I got.

enter image description here

I have no idea how to go about it after that. It is saying Secure boot forbids loading module, while loading Ubuntu I did secure boot by entering a password for that.

  • If booting the older kernel works, please file a bug against the new kernel. – Zanna Oct 15 '16 at 8:21
  • Sorry I can only direct you to this askubuntu.com/questions/5121/how-do-i-report-a-bug I looked on Launchpad but couldn't find that anyone had already reported your bug :S – Zanna Oct 16 '16 at 13:29
  • hi, I am having exactly the same issue with the new machine i just bought. it looks to me it's due to the kernel is loading some weird module that involves graphic display. you got anything new from your side? which kernel are you running now? – Jason Hu Jul 25 '17 at 1:57
  • @HuStmpHrrr 4.4.0-83-generic . This the current version – L.K. Jul 25 '17 at 9:38
  • 1
    Do you happen to have a nvidia card? That caused the problem me. – Jason Hu Jul 25 '17 at 11:07
16

I faced the same issue on my personal computer. It seems to come from packages of kernel 4.4.0-43 that have been released without other needed ones. See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1633267/comments/17

First try to boot an old kernel

Holding the shift key right after starting the machine should display the grub menu. Then you should be able to choose an old kernel in "advanced options".

If you manage to start your machine this way, you're lucky : you only need to upgrade to get the missing packages :

sudo apt update && sudo apt upgrade

If you can't boot the machine at all

In this case, I managed to solve it by running the upgrade from a live-USB key, through chroot :

If your system disk is not encrypted

  • start the computer on a live-USB or live-CD of the same version of Ubuntu (16.04.1)
  • mount your system disk (in /mnt in this example. If you mount it from the GUI, it will probably be in /media/ubuntu/some-uid : in this case, replace /mnt with this path below)
  • mount the necessary directories to allow your chroot to access the Internet :

    sudo mount --bind /sys /mnt/sys
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /run /mnt/run
    

    and, if you have a separate /boot partition : (adjust the device name)

    sudo mount /dev/sda2 /mnt/boot
    
  • then start the chroot and upgrade :

    sudo chroot /mnt
    apt update
    apt upgrade
    exit
    
  • and finally unmount everything and reboot (not sure it's really necessary) :

    sudo umount /mnt/sys
    sudo umount /mnt/proc
    sudo umount /mnt/dev
    sudo umount /mnt/run
    sudo umount /mnt/boot
    

If your system disk is encrypted

In this case, you first need to mount it with the same name as in your /etc/crypttab (in my case it was sda3_crypt : find yours in the first column of /etc/crypttab, on the line of your system disk) :

sudo cryptsetup luksOpen /dev/sda3 sda3_crypt
sudo mount /dev/mapper/ubuntu--vg-root /mnt

then follow the same procedure as above

I explained the complete story (in French) on my blog : https://blog.mossroy.fr/2016/10/14/ubuntu-bloque-a-la-saisie-du-mot-de-passe-de-dechiffrement-luks-a-cause-dun-kernel-4-4-0-43-incomplet/

  • Could you explain your current status, and what you precisely did, so far? Did you launch an upgrade? If you manage to have the grub menu, choose the line with 4.4.0-42-generic (no suffix), which should allow you to boot. Then upgrade – Mossroy Oct 16 '16 at 8:35
  • Thanks a lot for your reply. I edited my question, anyway I was able to go to grub menu without the need for live usb. Then I selected Advanced options from there I got this(above pic). – L.K. Oct 16 '16 at 9:30
  • +1, I did as you mentioned i.e. to select 4.4.0-42-generic. And then sudo apt update && sudo apt upgrade. Do I need to restart it again. Hope so that same problem won't come. – L.K. Oct 16 '16 at 9:37
  • Yes, the problem should be solved : reboot to check – Mossroy Oct 16 '16 at 11:14
  • The new kernel is not installed but the old one. If again the new kernel is installed then it will again start, the problem. – L.K. Oct 16 '16 at 11:56
2

Not a solution, but a quick fix:

I experienced the exact same thing from the update today.

My workaround is to boot the previous kernel, as described in this post from a year ago.

Access the GRUB menu by pressing shift after turning your computer on, select Advanced Options for Ubuntu and go down to the older kernel in the list (not recovery).

  • @Sarvva I can't access my grub, I tried pressing shift, directly ubutu screen is coming. – L.K. Oct 15 '16 at 10:50
  • @Sarvva I have updated the question. Do I need to select the lower one in the list? But which one exactly, there are lot. – L.K. Oct 15 '16 at 20:35
2

I experienced this issue upgrading from Xenial to Zesty. I tried the other solutions, but they didn't work for me.

Instead, when I reached the GRUB menu, I entered a recovery kernel. From there, I dropped to a root terminal, and run an apt update/upgrade, followed by the recovery system's "fix broken packages" option.

That seems to have fixed it for me. I think that, for some reason, the display server failed to finish updating, and so it was left in this half-broken state.

protected by Community Oct 14 '16 at 21:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.