Edit: now solved. See answer below, but I cannot accept it until two days hence.

My system (Laptop Dell Inspiron 15 7000 series 7548, dual boot Windows 10 & Xubuntu 16.04) has become unusable after installing a regular update (ubuntu base) via the software updater on my Xubuntu 16.04 system. The system does boot, but on first inspection, these are the problems:

1) mouse cursor is frozen

2) no network connection. sudo service network-manager restart does not solve the issue

3) Resolution has reset from 1920x1080 to native 3848X2160, making troubleshooting difficult (15.6' laptop screen)

While troubleshooting individual issues I have discovered that:

  • ifconfig -a just shows 'lo' but neither eth0 nor wlan0

  • /etc/modules does not list ANY modules to be loaded on boot

  • Manually adding psmouse and iwlwifi does not solve anything

  • Trying to run recovery mode (via GRUB boot) I get an error ' [FAILED] failed to load kernel modules'

  • Trying to either enable networking in recovery mode or repair packages results in graphical glitches with lines of terminal code (usually displayed during boot, of the style [ OK/FAILED ] < whatever it was loading > covering my screen in this fashion:

     Example code
          Example code
               Example code

Recovery mode also calculates the pixels on my screen wrong, meaning I can NOT see the current line of the terminal (although I can guess in some cases).

This is what I currently can do/acces to troubleshoot: - I can boot onto Xubuntu desktop and run applications/terminals with keyboard only. - I can open a terminal with cntl-alt-F2.

If anyone knows how to start solving this, other than creating a fresh install, I would be most grateful. Please keep in mind I am not a very experienced user, so patient, detailed instructions would be very much appreciated.

When requesting info/offering solutions, please keep in mind that: - I cannot copy/paste from linux to windows (where I am posting this from) and have to reboot to check anything, so logs etc I will have to photograph or type. - My laptop does NOT have an ethernet port. I have internetaccess in winwdows and can download things there, but cannot connect to wired internet under linux.

Thanks very much!

  • Right sorry, I was in a rush and tired of looking for the SOLVED option after 4 hours of troubleshooting ;). Thanks for pointing me in the right direction. I'll fix it now. – Narameh Oct 14 '16 at 15:16
  • Apparantly I am not allowed to accept my own answer until two days in the future so I'll leave the SOLVED in the title for now and explained all this with an edit ;). – Narameh Oct 14 '16 at 15:19
  • @Narameh Please don't put 'SOLVED' in the title. Just mark your question as accepted when you can. – Thomas Ward Oct 14 '16 at 15:21
  • @ThomasWard Okay :). Apologies! – Narameh Oct 14 '16 at 15:24
  • @LiveWireBT I'll paste in the commands. Can't remember now exactly which of the fiddles made me able to upgrade the GRUB though :S. – Narameh Oct 14 '16 at 15:25

After a fair amount of fiddling I was able to upgrade the GRUB loader via the repair mode, which gave me access to 'older' repair modes of xubuntu, which did manage to engage network mode. I then followed the instructions by kansasnoob in this thread which solved my issues.

In Recovery Mode the first thing you must do is select Enable networking. That not only enables networking but mounts the file systems in read/write mode which is necessary to do anything. You'll be asked for confirmation so just select yes and then you'll be returned to the menu again so select Drop to root shell. From there you'll need to run some commands to try and recover. It may be necessary to repeat these in no specific order as you proceed (no sudo needed because you are in a root shell):

apt-get update
dpkg --configure -a
apt-get dist-upgrade
apt-get -f install
  • And the command codes of that post were: sudo apt-get update sudo dpkg --configure -a sudo apt-get dist-upgrade sudo apt-get -f install Indent doesn't result in a code block here. If people would like me to fox this I am happy to, just give me a brief nudge how. – Narameh Oct 14 '16 at 15:25
  • Markdown works fine, just not in comments, they are supposed to be simple, code works with backticks and links with [text](link) in comments. askubuntu.com/help/formatting – LiveWireBT Oct 14 '16 at 15:43
  • @LiveWireBT I peeked at your edit to check out the formatting ;). – Narameh Oct 14 '16 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.