4

I have a problem and can't find a solution. I'm really new in linux system, so ask me for whatever you need.

My computer shut down suddenly when I ran some programs (like if I take out the electric power), clustalo tool was the first time, uninstall it, try to turn on the computer and have to use fsck on /dev/sda1 to start correctly. Next time it shut down when I try to compress some big files with pbzip2..., it's happened to me several times and some of them I have to start with the liveCD. So I thought the problem came from RAM. I checked with memtest86, but no errors were found. Maybe some corrupted data?

The computer is Fujitsu, it has 64GB RAM and 24 threads, several hard disks of 2T and is pretty new, less than a year. I use it for bioinformatics purposes and I install lots of tools, but have installed programs such as chrome, skype or dropbox too.

Any ideas? I had looked for a solution but I can't find a similar issue around

Could be when a program ask for more threads than possible? I ran pbzip2 -p16 two times and Ubuntu shutdown again... I hope one of the processes stop or wait,... not a system crash

Just now (10:38:41) I ran "pbzip -p20 my-file" and the computer shut down. When it start again I went to /var/log/syslog and copy the entries around that exact time:

Oct 17 10:26:47 invictus systemd[1759]: Received SIGRTMIN+24 from PID 3136 (kill).
Oct 17 10:26:47 invictus systemd[1]: Stopped User Manager for UID 108.
Oct 17 10:26:47 invictus systemd[1]: Removed slice User Slice of lightdm.
Oct 17 10:34:53 invictus dbus[1509]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
Oct 17 10:35:55 invictus systemd[1]: Started CUPS Scheduler.
Oct 17 10:41:56 invictus rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="1552" x-info="http://www.rsyslog.com"] start
Oct 17 10:41:56 invictus rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]
Oct 17 10:41:56 invictus rsyslogd: rsyslogd's groupid changed to 108
Oct 17 10:41:56 invictus rsyslogd: rsyslogd's userid changed to 104
Oct 17 10:41:56 invictus systemd-modules-load[893]: Inserted module 'lp'

not sure what I'm looking for...

I've tried another approach because only shuts down when asking for many threads. I've run memtest86 multithreading and it fails when is about 55% performed and with no messages, just shutdown and reboot.

  • Check /var/log/ for notices regarding errors, crash, overheating, and the sorts. grep {text} *.log helps with searching where {text} needs to be replaced with what you want to search. – Rinzwind Oct 14 '16 at 14:11
  • Hi Rinzwind, I did what you said and grep for 'error' 'crash' 'overheating', only error and crash get matches, and redirect the output to a file. How can I submit a file here? the results didn't have much meaning for me, as I told... I'm really new in this. – Jaime jiménez Oct 14 '16 at 16:27
  • A better approach would be to make a note of the time of the unexpected shutdown and poke around /var/log/syslog for the last entries around that time before the next boot. – David Foerster Oct 15 '16 at 21:31
  • @DavidFoerster, ok, I go to /var/log/syslog, what I am looking for? – Jaime jiménez Oct 17 '16 at 8:37
  • Could you please edit your post, when you want to add information? Especially file or program output listings (with the help of the {} button in the editor toolbar) will be much more readable there; alternatively you can use a pastie service for longer listings and include the link of your pastie in your question. Overall it’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons. – David Foerster Oct 17 '16 at 9:32
2

Finally I contact Fujitsu service because, instead all my tries to fix it, the computer continued shutting down when I launch process with high requirements. They just change the power supply and everything seems to work correctly now. I hope this will be useful for someone.

Thanks!!

| improve this answer | |
  • That makes sense now. 64 RAM and 28 threaded require a lot of current. But what triggered the absolute cut off? – Mohammed Joraid Aug 11 '17 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.