0

On a fresh installation of Ubuntu Desktop 16.04 I installed Transmission using this procedure:

sudo apt-get install transmission-cli transmission-common transmission-daemon
sudo service transmission-daemon stop
sudo nano /var/lib/transmission-daemon/info/settings.json

In the settings I changed download and incomplete folder destinations and umask set to "2", and add my username to debian-transmission group

sudo usermod -a -G debian-transmission username
sudo service transmission-daemon start

First download give me permission denied after few seconds.

So I tried to change the ownership and permissions on folders:

sudo chown username:debian-transmission /media/public/downloads
sudo chmod 770 /media/public/downloads

(The same have been done for for incompelete folder) but the problem is the same.

I attach output of ps -ef | grep transmission.

debian-+ 984 1 0 08:02 ? 00:01:30 /usr/bin/transmission-daemon -f --log-error
username 4365 4350 0 17:20 pts/17 00:00:00 grep --color=auto transmission

and ps aux | grep transmission.

debian-+ 984 0.2 0.2 345376 17516 ? Ssl 08:02 1:30 /usr/bin/transmission-daemon -f --log-error
username 4369 0.0 0.0 21312 976 pts/17 S+ 17:21 0:00 grep --color=auto transmission

Output of ls -l /media/public/downloads is:

drwxrwx---+ 2 username debian-transmission

The last information that could be useful to understand my situation is the incomplete and download folders are on mdadm device but I don't know how give you more details about it

  • Transmission is already installed and doesn't require any additional groups?? And permissions have to do with the partition/folder you're downloading to and not how or with what they were downloaded? I really don't understand why you're doing all that. – user589808 Oct 14 '16 at 12:31
  • Hi @CelticWarrion, I started all this assuming that transmission was not present in default Ubuntu installation. So probably I did it for nothing :( . I'll let you know. Thanks for this info – MarcoLmb Oct 14 '16 at 13:54
  • It is but even if not installed by default the first option should always be checking the official repositories where you would find it. It doesn't require special settings but if you change the default folders make sure you have rw permissions for the user running Transmission. Also applicable to any other then the default download location you may decide to download to eventually. – user589808 Oct 14 '16 at 14:06
  • It's installed only client version, I spoke about server version. The permission on download folder are in the last lines of my main post – MarcoLmb Oct 14 '16 at 19:09
0

the only work around that I found to solve this problem is to edit /etc/init.d/transmission-daemon and set the "USER" variable to "root"

I know it's not the right way but is the only one that allow transmission daemon to write files in destination folders

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.