3

I successfuly paired my new bluetooth keyboard (Netway, 77 keys, Win/MAC), but it works only as a numerical keyboard - mean that I am able to write only numbers over few letters in the right part of the keyboard and the rest doesn't work?!

I saw the same problem without any answer here:

Bluetooth keyboard wrong keymap

I prefer to buy another keyboard, than to modify a whole keyboard layout :P

Thank you guys for any possible answer.....

2
  • have you tried testing the keyboard with other devices and changing your keyboard layout – user590419 Oct 14 '16 at 8:12
  • Firstly - Thank you for your answer Jonluke! Yeap, it works great just with my phone (Android), also I crossed over couple of different layouts and nothing change. The comunication between keyboard is without any problem, but there is no way to write something.... Is there any way how to use the driver from Windows for Linux, or that is impossible? – Tom Zedinek Oct 15 '16 at 8:11
5

The issue is due to Numlock activating, resulting in part of the map being interpreted as a numeric keypad, and the rest doing nothing. At least with Apple compatible keyboards, the solution is to press Fn+F6 a couple of times to toggle Numlock off. You should also look into editing /etc/numlockx to disable Numlock by default. There is also a Gnome or X tweak mentioned at Apple Keyboard – Numlock on Apple Wireless Keyboard.

0

This post helped me a lot, but the answer was much simpler in my case. I had a wired keyboard connected to my computer besides the Apple bluetooth keyboard. NumLock was activated there. I just pressed the NumLock button in my other keyboard and things worked like a charm. Thanx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.