0

I have installed ubuntu succesfully, and tried repairing the trackpoint sensitivity following the instructions provided in this forum:

Increase Trackpoint Sensititvity with SystemD (Ubuntu 15.04 or later)

Then I installed some updates, about 15, from the ubuntu store application and restarted the machine. The computer got frozen when shutting down and then my booting problem started.

Afeterwards, I installed boot repair on a live usb and followed the instructions provided succesfully, but when I rebooted my system it took me to a black screen with a cursor blinking on the upper left side of the screen. I cannot get to start either windows 10 or Ubuntu.

This is the url that the boot repair gsoftware gave me given the case in which the problem continued:

http://paste.ubuntu.com/23319385/

Since I cannot get into windows, in my Lenovo Edge e330 computer, it is not possible for me to change the boot from legacy back to uefi.

Thank you for your help,

Ricardo

  • You go into UEFI to change setting from UEFI to legacy or vice-versa. UEFI and BIOS are not really compatible. You have to go into UEFI boot menu to boot. You cannot dual boot from grub menu as once you start booting in one mode, you cannot switch. Some systems require you to change UEFI settings, others will let you dual boot but only from UEFI boot menu, often f10 or f12 UEFI one time boot key. Is yours like this? Lenovo Thinkpad E531 - turn off locked boot order setting in UEFI ubuntuforums.org/showthread.php?t=2255746 – oldfred Oct 13 '16 at 20:28
  • Legacy or UEFI is normally set in your BIOS. Windows is not needed for this. When the computer boots, the BIOS splash screen will tell you what function key is required to enter BIOS setup. Hit that function key during the splash screen display, then change your settings back to UEFI. Cheers, Al – heynnema Oct 13 '16 at 23:37
  • The splash screen tells me that to interrupt normal start-up I should press the enter key. I have tried several times, also with other function keys such as f10 or f12 but cannot get to the bios. When I installed Ubuntu I was required to access the bios by restarting from within windows and to adjust the uefi and legacy option. – Ricardo Oct 14 '16 at 8:34
1

It looks like you've got a BIOS/CSM/legacy-mode install of Ubuntu and an EFI/UEFI-mode install of Windows. Mixing boot modes in this way can work in some cases, but at best it complicates the boot process, and at worst it's impossible. I'm not sure why your updates broke everything -- given the boot loader evidence in your Boot Repair output, if anything I'm surprised you had no problems before. (Were you hitting a key at start time to get the firmware's built-in boot manager to select which OS to boot?)

Since you've tried Boot Repair and it didn't work, I recommend you try the following:

  1. Download the USB flash drive or CD-R version of my rEFInd boot manager.
  2. Prepare a medium from the download.
  3. Boot to the rEFInd medium. It should show options to boot both Windows and Ubuntu.
  4. Select the Windows option in rEFInd to verify that it boots. If it doesn't, stop and diagnose the problem (posting back here, if necessary).
  5. Reboot back into rEFInd.
  6. Select an Ubuntu option. Chances are there will be just one, which will boot boot\vmlinuz-{version}. If there are multiple options, try a boot\vmlinuz-{version} option first, but if something else works, go ahead and use it.
  7. Once Ubuntu is booted, install the Debian package or PPA, as described in the rEFInd documentation.
  8. If the computer doesn't boot at this point, boot again to rEFInd on the removable disk. With any luck there will be an icon on the second row that will cause the computer to boot into its firmware setup utility. Use that and then disable BIOS/CSM/legacy support in your firmware. The computer should now boot to rEFInd, and from there to Windows or Ubuntu.

At this point, rEFInd should take over as the default boot manager, and give you options to boot either Windows or Ubuntu. It should work, but you may want to do further tweaking; see the rEFInd documentation for details.

What this procedure does is to install rEFInd, which will enable you to boot either Windows or a Linux kernel in EFI mode, bypassing your non-functional BIOS-mode GRUB. If you prefer to use GRUB, you can install an EFI-mode version of that boot loader instead of installing rEFInd once you get into Ubuntu via rEFInd on a removable medium. You'd do this by installing the grub-efi package and then running grub-install and update-grub. (That's from memory; I may be forgetting something critical or misremembering a detail.)

Note that the error that lead you here was this:

When I installed Ubuntu I was required to access the bios by restarting from within windows and to adjust the uefi and legacy option.

Whatever you read that suggested this was BAD ADVICE! See this page of mine for details on this issue. This bad advice was once quite common. It's fading in prominence, but unfortunately, lots of sites persist in spreading this bad advice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.