0

I have the exact same Kubuntu virtual machines set up on a Windows host and a Mac host in VirtualBox.

The VMs under the Mac can play web media right out of the box. The VMs under the Windows 10 host cannot play any media on Youtube, Soundcloud, etc.

I've tried installing different distros under the Windows host and I've tried installing all codecs, including Pepper Flash, Ubuntu restricted extras and Mint meta codecs. Nothing changes the fact that the Kubuntu and Mint VMs under a Windows host cannot play media, whereas the VMs under a Mac host work out of the box. I am puzzled why an identical installation on two hosts works differently.

I've requested HTML5 in Youtube but that doesn't load the videos either.

5
  • What happens if you clone a VM that works from the Mac and copy it to the Windows host? – Elder Geek Oct 13 '16 at 15:31
  • I've had the same issues but on a MAC host, tried several Linux distros. It works the first time I restore a snapshot or after reboot. But usually only once. Then it stops playing videos. – user606703 Oct 14 '16 at 5:25
  • Sometimes videos load, other times they don't and I have to restart. – Richard Fe. Oct 14 '16 at 14:07
  • This is what I'm experiencing on the Windows host. – Richard Fe. Oct 14 '16 at 14:25
  • On my openSUSE dual boot I am having the same issue. Sometimes media and sound works, other times I have to restart the computer. So I don't believe it is a Virtualbox-specific issue. – Richard Fe. Oct 15 '16 at 14:40
0

This may be a workable temp fix. Go back to VB 5.0.x. No flash or HTML5 content would play on one of my hosts' VMs but it worked perfectly on another's. Turns out it was working on the machine running virtualbox 5.0.26 whereas the other always froze at 0:00 when running under 5.1.8. Both are on Win10 host OSes.

I went both directions to confirm it. I upgraded the 5.0.26 to 5.1.8 and ran the same VM, installing the newer guest additions and software updates: all flash and HTML5 failed to run. The other machine I uninstalled virtualbox, reinstalled with 5.0.28, loaded the existing VM with guest additions and software updates, and flash/HTML5 worked perfectly.

Both VMs had the same version of flashplayer (11.2.x.644) and no settings were changed so the problem is something related to how 5.1.x works with kubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.