1

I am getting the following string of errors when running sudo apt-get update:

Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease                                     
Hit:2 http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial InRelease                      
Ign:3 http://extras.ubuntu.com/ubuntu precise InRelease                                   
Hit:4 http://dl.google.com/linux/chrome/deb stable Release                                       
Ign:6 http://archive.canonical.com/ubuntu precise InRelease                                      
Hit:7 http://ppa.launchpad.net/n-muench/burg/ubuntu xenial InRelease                      
Ign:8 http://us.archive.ubuntu.com/ubuntu precise InRelease                                      
Get:9 http://extras.ubuntu.com/ubuntu precise Release [11,9 kB]                                  
Hit:10 http://archive.canonical.com/ubuntu precise Release                                       
Hit:11 http://ppa.launchpad.net/noobslab/macbuntu/ubuntu xenial InRelease                        
Get:13 http://us.archive.ubuntu.com/ubuntu precise-security InRelease [55,7 kB]                  
Hit:14 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial InRelease                 
Get:15 http://extras.ubuntu.com/ubuntu precise Release.gpg [72 B]                                
Ign:15 http://extras.ubuntu.com/ubuntu precise Release.gpg                                       
Hit:16 http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu xenial InRelease   
Ign:18 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial InRelease               
Hit:21 http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial InRelease                   
Get:22 http://us.archive.ubuntu.com/ubuntu precise-updates InRelease [55,7 kB]
Hit:17 http://extras.ubuntu.com/ubuntu precise/main Sources                                      
Ign:17 http://extras.ubuntu.com/ubuntu precise/main Sources                       
Hit:19 http://extras.ubuntu.com/ubuntu precise/main amd64 Packages                              
Ign:19 http://extras.ubuntu.com/ubuntu precise/main amd64 Packages  
Ign:23 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial Release
Hit:20 http://extras.ubuntu.com/ubuntu precise/main i386 Packages   
Ign:20 http://extras.ubuntu.com/ubuntu precise/main i386 Packages   
Hit:24 http://us.archive.ubuntu.com/ubuntu precise-backports InRelease
Ign:25 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 Packages    
Hit:17 http://extras.ubuntu.com/ubuntu precise/main Sources                                     
Ign:26 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main i386 Packages
Hit:27 http://us.archive.ubuntu.com/ubuntu precise Release          
Hit:19 http://extras.ubuntu.com/ubuntu precise/main amd64 Packages        
Ign:29 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main all Packages
Hit:20 http://extras.ubuntu.com/ubuntu precise/main i386 Packages
Ign:30 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en_US
Ign:31 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en     
Ign:32 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:33 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main DEP-11 64x64 Icons 
Ign:25 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 Packages     
Ign:26 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main i386 Packages      
Ign:29 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main all Packages       
Ign:30 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en_US  
Ign:31 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en     
Ign:32 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:33 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main DEP-11 64x64 Icons 
Ign:25 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 Packages     
Ign:26 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main i386 Packages      
Ign:29 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main all Packages       
Ign:30 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en_US  
Ign:31 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en     
Ign:32 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:33 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main DEP-11 64x64 Icons 
Ign:25 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 Packages     
Ign:26 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main i386 Packages      
Ign:29 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main all Packages       
Ign:30 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en_US  
Ign:31 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en     
Ign:32 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:33 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main DEP-11 64x64 Icons
Ign:25 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 Packages
Ign:26 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main i386 Packages
Ign:29 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main all Packages
Ign:30 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en_US
Ign:31 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en
Ign:32 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:33 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main DEP-11 64x64 Icons
Err:25 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 Packages
  404  Not Found
Ign:26 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main i386 Packages
Ign:29 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main all Packages
Ign:30 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en_US
Ign:31 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main Translation-en
Ign:32 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:33 http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial/main DEP-11 64x64 Icons
Fetched 123 kB in 35s (3.456 B/s)
Reading package lists... Done
W: http://archive.canonical.com/ubuntu/dists/precise/Release.gpg: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
W: GPG error: http://extras.ubuntu.com/ubuntu precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192
W: The repository 'http://extras.ubuntu.com/ubuntu precise Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: http://us.archive.ubuntu.com/ubuntu/dists/precise-security/InRelease: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
W: http://us.archive.ubuntu.com/ubuntu/dists/precise-updates/InRelease: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
W: The repository 'http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: http://us.archive.ubuntu.com/ubuntu/dists/precise-backports/InRelease: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
W: http://us.archive.ubuntu.com/ubuntu/dists/precise/Release.gpg: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
E: Failed to fetch http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

What do these errors mean, and how can I fix them?

My sources.list file content is

#############################################################
################### OFFICIAL UBUNTU REPOS ###################
#############################################################

###### Ubuntu Main Repos
deb http://us.archive.ubuntu.com/ubuntu/ main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse

###### Ubuntu Update Repos
deb http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

###### Ubuntu Extras Repo
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main
  • 1
    What version of Ubuntu are you using? – Arronical Oct 13 '16 at 14:24
  • askubuntu.com/users/320386/arronical iam using elementary OS kernel ubuntu 16.04 – NORRIS RAHMAN Oct 13 '16 at 14:39
  • 1
    Welcome to Ask Ubuntu! Unfortunately questions about Elementary OS are not supported here. Ask Ubuntu only supports questions about official flavours of Ubuntu OS. There is a specific ElementaryOS stack exchange site where this question would be considered on-topic on the ElementaryOS SE. – Arronical Oct 13 '16 at 14:47
3

From your apt-get update output I can see that you've precise repositories in Xenial, which is the source of the problem. You should remove those lines from your sources.list file.

  1. First open the file using this command in a terminal

    sudo -i gedit /etc/apt/sources.list
    
  2. Then remove all lines that have precise in it.

  3. Then save the file and exit gedit. Now do sudo apt-get update.

The problem should be gone.

| improve this answer | |
  • cant you speak indonesian – NORRIS RAHMAN Oct 13 '16 at 14:41
  • No. I don't speak indonesian. Do you have problem understanding the answer? – Anwar Oct 13 '16 at 14:43
  • Which Should be eliminated – NORRIS RAHMAN Oct 13 '16 at 14:43
  • no, i understand you speak – NORRIS RAHMAN Oct 13 '16 at 14:44
  • You'll see many lines in /etc/apt/sources.list file. You will remove every line that has precise word in it – Anwar Oct 13 '16 at 14:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.