Hi :) I've recently bought a new PC with Palit GeForce GTX 1060 6GB Dual video card. Unfortunately, it seems like Ubuntu has some problems with it. When I type "sudo lshw -C display", I get this message:

 *-display UNCLAIMED
   description: VGA compatible controller
   product: NVIDIA Corporation
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller cap_list
   configuration: latency=0
   resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff

   description: VGA compatible controller
   product: Sky Lake Integrated Graphics
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915_bpo latency=0
   resources: irq:124 memory:f5000000-f5ffffff memory:d0000000-dfffffff ioport:f000(size=64)

and when I go to "Additional drivers", I get this: Unknown: Unknown. The device is using an alternative driver.

  • You probably need the ppa for very newest drivers. askubuntu.com/questions/813676/…
    – oldfred
    Oct 12, 2016 at 21:04
  • And how do I get this ppa? I've written: ubuntu-drivers devices ... ubuntu-drivers devices | grep recommended ... sudo apt-get remove --purge nvidia-* ... sudo ubuntu-drivers devices ... sudo ubuntu-drivers autoinstall ... ubuntu-drivers devices ... sudo apt-add-repository ppa:graphics-drivers/ppa ... ubuntu-drivers devices just as they said in the post You linked to, but that didn't change anything (by anything, I mean I still get the same messages as I described in the question). Sorry, I'm a linux newbie.
    – Jecke
    Oct 12, 2016 at 21:38
  • In "Software & Updates", I've change "Download from:" from "Poland server" to "Main server" and something new appeared: s17.postimg.org/a0ycqs4e5/… still, VGA compatible controller appears as UNCLAIMED
    – Jecke
    Oct 12, 2016 at 21:52
  • But this is super old. Ubuntu 10 and gtx 560? I would think something could change for the last 5 years. I'll try to follow the answers anyway
    – Jecke
    Oct 12, 2016 at 22:21
  • I tried following these instructions. I used sudo add-apt-repository ppa:graphics-drivers/ppa and sudo apt-get install nvidia-367 ...and now nothing works. System boots normally, but when the login screen shoul appear, everything goes black and monitor goes into sleep mode... I've discovered that using ctrl+alt+f1 brings up terminal, but that's all. I think that nothing graphics-related works...
    – Jecke
    Oct 12, 2016 at 22:51

3 Answers 3


Disable Secure Boot in BIOS. With Secure Boot enabled proprietary drivers will never load. Then run in a terminal

sudo apt purge 'nvidia.*'
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-367 nvidia-prime

The 367 driver is a recommended by Nvidia LTS driver.

  • 1
    What does nvidia-prime do? I heard it's for laptops?
    – Jecke
    Oct 13, 2016 at 18:41
  • also - could You please tell me how to disable secure boot? In bios, there is a section where it says "Secure boot - enabled", but it's grayed out, so I cannot change it.
    – Jecke
    Oct 13, 2016 at 18:48
  • it looks very much like this
    – Jecke
    Oct 13, 2016 at 18:49
  • ok, I somehow managed to disable secure boot (deleted all "keys" under the "Secure boot" option). I installed the drivers and what happened is what have happened each time before - after turning on the PC, it goes completely black, monitor goes into the sleep mode and the only thing I can do is enter the terminal by ctrl+alt+f1. Everything goes back to normal after I purge 'nvidia.*
    – Jecke
    Oct 13, 2016 at 19:13
  • Deleting keys is wrong. You need to disable Secure Boot option.
    – Pilot6
    Oct 13, 2016 at 19:32

I had the exact same problem with the GTX 1060 and 16.04. I followed all of the instructions here and in other threads but couldn't get past the login screen.

I was able to get it working by installing ubuntu 14.04, having secure boot disabled (I don't know if this matters I had just already tried it and kept it that way just in case - I may follow up if I try again with it on), and installing the proprietary drivers.

To install the proprietary drivers these are the exact steps I took. We have similar models so it might work for you.

CTRL+ALT+F1 #if you haven't already

sudo service lightdm stop 
cd ~/Downloads
wget http://us.download.nvidia.com/XFree86/Linux-x86_64/367.57/NVIDIA-Linux-x86_64-367.57.run
sudo chmod +x NVIDIA-Linux-x86_64-367.57.run
sudo ./NVIDIA-Linux-x86_64-367.57.run
sudo reboot

The driver install was done after a completely fresh install of ubuntu 14.04.5.

Here are some of my parts just in case it helps.

  • ASUS Z170-A LGA 1151 Intel Z170 HDMI SATA 6Gb/s USB 3.1 USB 3.0 ATX Intel Motherboard
  • Intel Core i7-6700K 8M Skylake Quad-Core 4.0 GHz LGA 1151 91W BX80662I76700K Desktop Processor Intel HD Graphics 530
  • SAMSUNG 850 EVO 2.5" 500GB SATA III 3-D Vertical Internal Solid State Drive (SSD) MZ-75E500B/AM
  • MSI GAMING GeForce GTX 1060 6GB GDDR5 DirectX 12 VR Ready (GeForce GTX 1060 GAMING X 6G)
  • 2
    This is a bad solution because you will get a black screen after the first kernel upgrade.
    – Pilot6
    Feb 6, 2017 at 16:16

The default drivers installed for the graphics card in Ubuntu is nouveau. This works fine for most of the times but at certain stages it is just not enough. On the other hand ppa's can be an alternative solution but in the long run it may cause minor damages to hardware.


1) Download the official drivers from the Nvidia website.

2)Run the installer script as root user

sudo sh "driver name".run

3) Reboot the system

Not the answer you're looking for? Browse other questions tagged .