1

I am about to loose my mind over this. I am using Ubuntu 14.04 LTS on a Lenovo T430s laptop with an Intel 82579lm ethernet card. I can get internet access via wifi (private router) without any problem. If I connect the laptop via an ethernet cable, I do get an IP-adress via DHCP, but I cannot access the internet via browser or ping anything. However, under Windows 7, which is also installed on the laptop, the ethernet connection works perfectly. So I can be sure it is no router or cable problem.

The driver version for the ethernet card (e1000e) is 3.2.6-k.

I've been searching all day for a solution, but nothing actually worked. Anybody has any idea? I'll post any command output needed, just let me know what I can do to help.

Thank you!

Edit: Using ifconfig I get the following output for eth0:

Link encap:Ethernet HWaddr 3c:97:0e:26:37:ab
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::3e97:eff:fe26:37ab/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:158 errors:0 dropped:0 overruns:0 frame:0
TX packets:495 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:25044 (25.0 KB) TX bytes:57507 (57.5 KB)
Interrupt:20 Memory:f3500000-f3520000

So looks like some packets actually go through but no internet connection can be established

  • Just to rule the easy things out: Click onto the network symbol then choose "Edit Connections ...". Is there a category called "Ethernet" with any entries? – UTF-8 Oct 12 '16 at 20:17
  • Yes, there is an ethernet connection there called "Ethernet connection 1" which is configured to DHCP on IPv4, has the Mac adress of the ethernet card (eth0) and an MTU of 1500. – user606099 Oct 12 '16 at 20:21
  • Unplug your Ethernet cable, delete that connection, and plug it back into your computer. Does it work? – UTF-8 Oct 12 '16 at 20:52
  • No it does not. I have also tried a live version of 16.04 LTS, same problem. – user606099 Oct 12 '16 at 20:56
1

Alright so in case anybody else has the same issue I found a workaround:

I killed the loopback ('lo') interface that appeared when using ifconfig with the command 'sudo ifconfig lo down' which immediately led to pings going through again. After a reboot the interface showed up again and everything worked the way it was supposed to. No idea where the problem actually was, but hey it works ...

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy