0

After upgrading to 16.04, when I type into a javascript text field like this search field, every keystroke erases the one before it. I've also noticed subtly different behaviour in the location bar; matching URLs are no longer pre-selected until I cursor down.

I have removed my entire ~/.mozilla directory, purged firefox* (and manually deleted all the hanging firefox files in /etc and /usr/lib).

Even after what should be a completely fresh install of Firefox 49.0 (and a short try with an early v48 build), the problem persists. The only way I can make the behaviour stop is to disable javascript in about:config.

Possibly related: when I attempted to post this question with Firefox, the post hung, and I got an error from StackExchange about an unusually high number of requests.

Anyone else seeing anything similar? What else can I try?

UPDATE:

It's more than just Firefox. All gecko-based applications seem to be misinterpreting keyboard input, as was Eclipse. I suspect keystrokes were going to the wrong windows, somehow.

1

Alt-Gr key not working properly on Firefox

The solution is, to activate the checkbox Prevent accessibility services from accessing your browser in Firefox settings under Privacy & Security -> Permissions

  • Can't accept (no way to test) but it's always good to have other options to test for next time. Thanks! – Autumn Dec 18 '17 at 17:24
1

A better workaround is to disable IBus, as described at the bottom of this thread https://bugs.launchpad.net/unity/+bug/1484157

As said on the ubuntu-fr forum, you could avoid the bug by going in system option ▸ languages ▸ Input keyboard system and selecting an option other than IBus. (https://forum.ubuntu-fr.org/viewtopic.php?id=2020851)

  • Can't test it until next time it happens, but your answer seems plausible. Have an upvote. – Autumn Feb 23 at 21:51
0

Well, after a week of fiddling, I gave up and deleted ~/.config. That fixed my specific problem, but it sure would've been nice to actually solve the problem. Marking solved, but if you figure it out, please post a new answer.

0

I had the same issue and deleting ~/.config/dconf solved it.

  • This is really poor answer. You need to provide good answer with more information. – Eranda Peiris Jun 3 '18 at 2:04
  • I disagree. It would benefit from more info, but even without, it is potentially useful to others to know that it may not be necessary to delete all of .config/ – Autumn Jun 3 '18 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.