5

I'm getting ubuntu-make error whenever I'm using apt-get install command, can some one help?

~ sudo apt-get -f install                              
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up ubuntu-make (16.09~trusty1) ...
/var/lib/dpkg/info/ubuntu-make.postinst: 6: /var/lib/dpkg/info/ubuntu-make.postinst: register-python-argcomplete3: not found
dpkg: error processing package ubuntu-make (--configure):
 subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
 ubuntu-make
E: Sub-process /usr/bin/dpkg returned an error code (1)
9

Remove the ubuntu-make:

sudo apt-get remove --purge --auto-remove ubuntu-make

Show the available python3-argcomplete versions:

sudo apt-cache showpkg python3-argcomplete

Install the correct python3-argcomplete version (in my case):

sudo apt-get install python3-argcomplete=0.8.1-1ubuntu2

Reinstall ubuntu-make:

sudo apt-get install ubuntu-make

  • sudo apt-get remove --purge --auto-remove ubuntu-make made it for me – cwhisperer Jan 17 '18 at 13:53
2

I'm aware this question was asked in 2012, but you can encounter the same error message in 2016 with Ubuntu 16.04, as I did.

This is the ubuntu-make issue #350.

Most probable issue is that you use the postgres ppa which upgraded python3-argcomplete from 0.8.1 to 1.0.0 wich is not yet compatible with ubuntu-make.

Solution is either to deactivate the ppa or to tell apt not to use the postgres version of python3-argcomplete by creating a preference file like the following one:

$ cat /etc/apt/preferences.d/pgdg.pref
Package: *
Pin: release o=apt.postgresql.org
Pin-Priority: 500

Package:  python*
Pin: release o=apt.postgresql.org
Pin-Priority: 400

Then reinstall ubuntu-make and confirm it's the 0.8.1 version (not the 1.0.0 one).

  • 1
    This worked for me, thanks! Although since I had already upgraded python3-argcomplete and had cleared my apt cache due to running out of space, I had to uninstall it (sudo apt-get remove python3-argcomplete), then download the old version's .deb manually from here: ftp.ubuntu.com/ubuntu/ubuntu/pool/universe/p/python-argcomplete and install with dpkg -i python3-argcomplete_0.8.1-1ubuntu2_all.deb. – Abe Voelker Nov 12 '16 at 14:10
1

Try 'apt-file register-python-argcomplete3' to find what other package provides the missing package the install command is stumbling upon. After you find another package providing that file, install it, and try this install again.

Sorry, I'm on my phone and it's not letting me scroll over to see the debug output anymore.

  • I'm sorry, but can you edit your answer to clarify what "register-python-argcomplete3" has to do with the question? – Elder Geek Oct 12 '16 at 17:43
  • @kyle-h, I did not install apt-file, but search it here, I tried force reinstall for referred package but no luck, so i finally removed 'ubuntu-make' :( Thanks for your help! – sagarr Oct 13 '16 at 14:56
  • what about if you use the pip python package manager, can you find it there? just looking for that package on Google I don't see a version 3 deb at all. only see 1.5.1 – Kyle H Oct 13 '16 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.