3

I've got a new PC with a GTX1060 graphics card, and I can't get it to work.

I've installed Ubuntu Server 16.04 and LXDE, which is the combination I want, and works perfectly well, but although the Nvidia drivers (367) seem to be installed, the only graphics output which is enabled is the built-in i915.

I first tried adding the Nvidia PPA (http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu/) and using apt-get to install from there. I've also tried downloading the NVidia binary from the Nvidia website, rebooting into recovery mode (so X isn't running) and installing that. Both of these complete quite happily, but when I reboot into X, the "NVIDIA X Server Setting" tool (which has appeared in the "Preferences" submenu) claims "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server." when I run it.

This is odd, because the Nvidia installer runs nvidia-xconfig as part of its setup. I've also tried running it myself, and it doesn't alter the xorg.conf. My xorg.conf file contains

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

at the top, and

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

in the (only) Device section.

I've blacklisted nouveau (which lsmod now shows isn't installed), and lsmod gives

lsmod | grep nv
nvidia_drm             45056  0
nvidia_modeset        765952  1 nvidia_drm
nvidia              11489280  1 nvidia_modeset
drm_kms_helper        155648  2 i915_bpo,nvidia_drm
drm                   364544  5 i915_bpo,drm_kms_helper,nvidia_drm

But still, the only monitor working is the one plugged into the i915!

xrandr lists the two monitors plugged into the GTX1060:

Screen 0: minimum 8 x 8, current 1440 x 900, maximum 32767 x 32767
DP1 connected primary 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 256mm
   1440x900      59.89*+
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      85.00    75.08    70.07    60.00  
   832x624       74.55  
   800x600       85.06    72.19    75.00    60.32    56.25  
   640x480       85.01    75.00    72.81    66.67    60.00  
   720x400       70.08  
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

(that's HDMI 1 and 2), but they both show as disconnected despite being plugged in and turned on. Commands like xrandr --output HDMI1 --auto return happily, but have no effect.

lspci for the GTX1060 gives

01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c03 (rev a1) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device 85a4
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    Expansion ROM at f7000000 [disabled] [size=512K]
    Capabilities: [60] Power Management version 3
    Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [78] Express Legacy Endpoint, MSI 00
    Capabilities: [100] Virtual Channel
    Capabilities: [250] Latency Tolerance Reporting
    Capabilities: [128] Power Budgeting <?>
    Capabilities: [420] Advanced Error Reporting
    Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
    Capabilities: [900] #19
    Kernel driver in use: nvidia
    Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

which clearly shows that it's using the nvidia driver.

I'm at my wit's end with this. I eventually need to get CUDA and various machine-learning stuff working on this GPU, but I've fallen at the first hurdle of getting it to display on a monitor!

  • FYI, you should install the Nvidia driver via Additional Drivers, because it takes care of all the blacklisting stuff for you. – Android Dev Oct 12 '16 at 16:41
  • The "Additional Drivers" tool doesn't exist in LXDE, it's part of Gnome/GTK. I checked! – TomG Oct 12 '16 at 16:59
2

LXDE doesn't support hardware acceleration... So what you're trying to do (LXDE on a server with hardware video acceleration) is impossible at the time of this writing.

The only solution is: Choose another Desktop Environment..

Sorry! :-(

  • ... Wow. That is NOT the answer I expected after 3 days work! Um. – TomG Oct 12 '16 at 16:56
  • 1
    Where can I look up what other light/minimal desktop environments DON'T support acceleration, so I don't make the same mistake again? And THANK YOU for the super-fast answer which has saved me from endlessly banging my head against that particular wall! – TomG Oct 12 '16 at 16:58
  • :D I use LXDE for very old laptops without nVidia and Unity for laptops with... (favour returned: Question upvoted, so you're an 8-rep user already!) – Fabby Oct 12 '16 at 17:01
  • Ugh. A quick Google suggests that only DEs like Unity support it. I'm old enough that I've used LXDE and similar minimal GUIs for donkey's years, and I hate Unity, but it looks like I'll have to find out how to reconfigure it to be less horrible... Thanks again :) – TomG Oct 12 '16 at 17:07
  • 1
    @Fabby - I couldn't even get the "close" button on the right side of the windows. I've now discovered Cinnamon, which is old-fashioned enough to make me happy, but seems to use the GPU nicely. If I can get CUDA et al working, I'll be very pleased. :) – TomG Oct 13 '16 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.