27

My OS is Ubuntu 14.04. I am trying to download a a 3.6.x firefox version. I've gotten this one. According to the README, all I have to do is unpack, enter the folder and run ./firefox. However, I get the following error when I do that:

./firefox-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot 
open shared object file: No such file or directory.

But when I run locate libgtk-x11, it is installed:

/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0.2400.23

Does anyone know where ./firefox looks for? My guess is that I have to create a link between folders, I just do not know which.


Edit 1: After installing libgtk2.0-0:i386 and trying to run ./firefox again, the libraries libgobject-2.0 can not be found. I try to install them with sudo apt-get install libglib2.0:i368, but I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libglib2.0-0-refdbg:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dbg:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dev:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-data:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-doc:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0-dbg:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-bin:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil-dev:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-tests:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-data' instead of 'libglib2.0-data:i386'
Note, selecting 'libglib2.0-doc' instead of 'libglib2.0-doc:i386'
libglib2.0-data is already the newest version.
libglib2.0-doc is already the newest version.
libglib2.0-0:i386 is already the newest version.
libglib2.0-0:i386 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-cil:i386 : Depends: cli-common:i386 (>= 0.5.6) but it is not installable
                       Depends: libmono-corlib4.0-cil:i386 (>= 2.10.1) but it is not installable
                       Depends: libmono-system4.0-cil:i386 (>= 2.10.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

Maybe libglib2 is not the library that contains libgobject?

48

Your system is 64-bit, but since you want to run a 32-bit version of Firefox, you need to install the 32-bit version of the library:

sudo apt install libgtk2.0-0:i386
| improve this answer | |
  • thanks! I now get libgobject-2.0 not found, I have tried with sudo apt-get install libglib2.0:i368, but dependencies such as cli-common:i368, and others are not installable. Any ideas? Should I install a 32-bit system in a virtual box? – regina_fallangi Oct 12 '16 at 16:21
  • I'm not sure why it would want to pull cli-common, please edit your question to add the full output of apt install libglib2.0-0:i386. – fkraiem Oct 12 '16 at 16:29
  • It interprets libglib2.0-0:i368 as a regex and tries to install many packets. I am looking for the correct library for libgobject-2.0. Or you think it is something else? (Edit has been done) – regina_fallangi Oct 12 '16 at 16:56
  • It is really libglib2.0-0, not libglib2.0. – fkraiem Oct 12 '16 at 17:00
  • after sudo apt-get install libglib2.0-0:i386, the libraries libjobject-2.0.so.o still can not be found. Thanks for the correction, though. – regina_fallangi Oct 12 '16 at 17:03
3

I was having the same problem. @fkraiem answer made me figure out another possibility that fix my issue.

I was trying to run a app in the wrong architecture. So make sure if you are trying to install the right app for your system a 32 or 64 bits.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.