0

I get an error every time I try to install fluidsim. It seems that it is due to the library fft3w. I checked this library, and it is well installed on the system. The error is the following:

/usr/bin/ld: cannot find -lfftw3f
/usr/bin/ld: cannot find -lfftw3l
/usr/bin/ld: cannot find -lfftw3_threads
/usr/bin/ld: cannot find -lfftw3f_threads
/usr/bin/ld: cannot find -lfftw3l_threads
collect2: error: ld returned 1 exit status
error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
Makefile:4: recipe for target 'develop' failed
make: *** [develop] Error 1
(Env) mikel@Miguel:~/Env/fluidsim$ 

I could not figure out what is the problem. Do you have any idea what's the matter? Thank you for the help.

mikel

(Env) mikel@Miguel:~/Env/fluidsim$ dpkg -l|grep libfftw3
ii  libfftw3-double3:amd64                      3.3.4-2ubuntu1                                              amd64        Library for computing Fast Fourier Transforms - Double precision
ii  libfftw3-single3:amd64                      3.3.4-2ubuntu1                                              amd64        Library for computing Fast Fourier Transforms - Single precision
1
  • What version of Ubuntu are you using? please edit your question to include the output of dpkg -l | grep libfftw3 Oct 12, 2016 at 20:16

1 Answer 1

1

It looks like you don't have all of the libfftw3 component packages installed - perhaps because you installed libfftw3-single3 and libfftw3-double3 instead of the complete libfftw3-dev development package.

Try (re)installing libfftw3-dev

sudo apt install --reinstall libfftw3-dev

and if that doesn't work, try installing the sub-packages directly

sudo apt install --reinstall libfftw3-long3 libfftw3-single3
1
  • Sorry for the delay in the response! I had personal issues!! I tried what you told me and it worked!! Thanks for the help
    – mikel
    Oct 28, 2016 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.