It concerns Auqaris BQ M10 FHD with nice 10" screen. I tried to use the trick: create file


and set Xft.dpi: 224 inside it (see xmir-setup on XDA).

This trick helps for Geany, Firefox, LibreOffice, but doesn't help for Djview4. Trick works with DPI for fonts, but doesn't for menu icons and pictures. An other way I know can found there, I didn't test it, because of necessary to made system part writable.

I think this problem is similar to HiDPI with Retina in Linux. In usual Linux we can try to use

  Section "Monitor"
        Identifier     "<default monitor>"
        Option        "DPI" "224 x 224"

in xorg.conf.d/90-monitor.conf or use xrandr --dpi 224. But we have Libertine and I don't know how to solve this problem.

  • DPI is a known issue in libertine apps on high-resolution screens. The current suggested workaround is to set the system to read-writable and update the line in /usr/bin/libertine-xmir to be exec Xmir -dpi 144 -title @ $@ like in the link you included. This is a temporary workaround that should be fixed eventually, but it gets the job done for now on the M10. I'd be very interested if you found a better alternative. – Larry Price Oct 12 '16 at 14:18
  • FYI here's the bug I mentioned: bugs.launchpad.net/ubuntu/+source/libertine/+bug/1572888 – Larry Price Oct 12 '16 at 14:26
  • Is it risky to set the system to read-writable? What is best way to set so? For example with using these: phablet-config writable-image or touch /userdata/.writable_image or android-gadget-service enable writable? Could I possible to get OTA after this? – Vladimir Oct 12 '16 at 17:19
  • I would use phablet-config writable-image. You'll still receive OTA updates unless you start removing parts of the system that deal with updates. Avoid using apt if you want to continue getting OTA updates. – Larry Price Oct 12 '16 at 19:11
  • Ok, Larry. I'll try to test this method, and if it will work for my applications, I will set is as answer. In any case, I don't know how to apply other methods like xrandr --dpi 224 in Libertine. – Vladimir Oct 13 '16 at 5:10

DPI is a known issue in libertine apps on high-resolution screens, currently captured in this bug: https://bugs.launchpad.net/ubuntu/+source/libertine/+bug/1572888

The suggested workaround for the M10 FHD is mentioned in the pastebin linked in the question, but I'll post the important parts here for future readers.

Make the tablet temporarily writable:

phablet-config writable-image

Perform a restart on the tablet, and then log in with adb or phablet-shell. Edit the file /usr/bin/libertine-xmir and change the exec line:

exec Xmir -dpi 144 -title @ $@

where 144 is your preferred DPI number. Once finished editing, I recommend making the tablet read-only again:

sudo rm /userdata/.writable_image

The next time you restart, your tablet will be in readonly mode again. The change to /usr/bin/libertine-xmir could be reverted by any updates to libertine (OTA or otherwise). Hopefully this issue will be prioritized eventually and we won't need this hack.

  • Larry, I've tested it and can say the result is similar of using .Xdefaults file. The font's size works, icon's size does not. (Unfortunately, I deleted Djview4, it would be interesting to see the effect of new method in this application. It was bad with font size, and the size of icons previously.) Title of windows is very thin in both cases. But thanks for very nice "howto" about writable-status! – Vladimir Oct 14 '16 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.