6

I don't know if anyone can help me with gcc-5-base issue. Ever since I upgraded my 14.04 LTS to 16.04 LTS, I have packages with unmet dependencies.

The following packages have unmet dependencies:
libstdc++6 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.2) but 5.4.1-2ubuntu1~14.04 is installed
libstdc++6:i386 : Depends: gcc-5-base:i386 (= 5.4.0-6ubuntu1~16.04.2) but it is not installed
               Depends: libc6:i386 (>= 2.18) but it is not installed
               Depends: libgcc1:i386 (>= 1:4.2) but it is not installed
E: Unmet dependencies. Try using -f.

I wanna ask if there is a way to roll-back 5.4.1-2ubuntu1 to 5.4.0-6ubuntu1. Thanks!

  • Did you have the toolchain-r PPA enabled before upgrading? – steeldriver Oct 12 '16 at 5:54
  • No I didnt. I installed it and everything is working now. I am not getting complaints about previous gcc version. Thanks! – CodeCodey Oct 13 '16 at 4:45
  • 2
    sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update – Josh.F Nov 16 '16 at 9:19
11

In addition to what the OP describes, my do-release-upgrade was interrupted by this issue. Josh.F's comment did the trick for me:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get -f install

That fixed gcc-5 for me and then I still needed to sudo apt-get upgrade

1

The comment by @josh-f fixed this for me:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install -y r-base-dev
0

I had to add

deb http://cz.archive.ubuntu.com/ubuntu xenial-updates main

to /etc/apt/sources.list then

apt-get update apt-get install -f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.