A few days ago I had a hard drive failure, which was running Windows XP (32-bit) just fine. The second hard drive in my computer held a few unimportant files, so I formatted it in the Ubuntu setup and installed 11.10 without a hitch. I had been using it for about a week, but decided to install Windows 7 (64-bit) in order to utilize Networking with my home server (running Windows Server 2000). My system is 64-bit based, and thus I had no problems installing other than a basic RAM error that required me to remove my RAM down to a single stick. I played with the settings in Windows 7 for around an hour before I shut down. After reinstalling the RAM, Windows 7 would not boot. In this, I then assumed that something about my system was rejecting Win7 and I reinstalled Ubuntu. However, now Ubuntu (11.10) boots into black screen, and I've already attempted activating the grub menu with the shift key, and following steps listed here: https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen but nothing seems to work. I've reinstalled twice now, with the same result each time.

Now, the very odd part about this whole scenario is that the USB I installed from has no problems booting as a live USB. This puzzles me greatly, because the hard drive boots straight to black screen and the live USB loads normally. At this point, my only theory is that the boot sector of the hard disk was somehow corrupted with Win7, and that Ubuntu was unable to completely write through. I used Darik's Boot n Nuke to wipe the drive, but was met with an error, this also puzzles me because the hard disk has no promblems reading or writing. Any suggestions/comments are appreciated. If you have a theory, I will be more than happy to oblige.

Additional information:

Intel Core2 Duo e6400 2.13GHz

nVidia GeForce 7-series (7900 GS)

4 GB DDR2 333MHz (2x 2GB)

Dell XPS 410 BIOS Revision 2.5.3


I apologize for taking up space here, but I discovered the problem on my own earlier today. I ran a diagnostic on my harddrive after running a boot repair utility. After running the utility, I received, "Unexpectedly disconnected from boot daemon." This prompted me to perform a full scan diagnostic on the drive, which kept returning an error. I then attempted using DBAN, or Darik's Boot 'n' Nuke, again but was also met with an error here. I ran the drive in an external enclosure and ran a scan from another computer. This time I turned up the problem: A corrupted boot sector on the physical disk. While this will require a rebuild (a new hard drive), I recommend that anyone else who encounters this problem take heed from this post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.