I had been using Remmina version 0.99.x or something similar for a while, when I decided to upgrade to a higher version, due to Remmina crashing often when copying (using Ctrl+C) or cutting (using Ctrl+X).

I upgraded using similar steps as outlined in this answer, adding Remmina's master PPA.

sudo add-apt-repository ppa:remmina-ppa-team/remmina-master
sudo apt-get update
sudo apt-get install remmina remmina-plugin-rdp

But when trying to connect to a Windows machine, Remmina threw up a pop-up that told me that

Protocol plugin RDP is not installed.

I tried fixing this, but to no avail, even purging Remmina and installing it again (I must admit, without a reboot in between).

sudo apt-get purge remmina-*
sudo apt-get autoremove
sudo apt-get install remmina remmina-plugin-vnc remmina-plugin-rdp

But nothing has worked so far. I've switched to rdesktop, but how can I fix Remmina?

up vote 4 down vote accepted

I just ran into this myself (Kubuntu 14.04 LTS). I had the basic remmina package installed, but I wanted to add in all the optional protocols. I think I figured out why rebooting fixed the problem for you: the remmina process persists. It seems that when you close Remmina, you just close the GUI - the binary is still running, and it needs to be stopped and restarted to be aware that you've given it new plugins. At least, that's what happened in my case, and it explains what you observed - a quick killall remmina at the beginning saves a reboot cycle.

So, here's my method for a fresh Remmina install, with all the client protocols, on any *buntu variant, without nuking any saved connection profiles!

  1. Clean your environment:

    sudo killall remmina
    sudo apt-get purge remmina* -y
    rm -Rf /home/`whoami`/.remmina/remmina.pref
    
  2. (Optional) Add the Remmina repo to get the latest build:

    sudo add-apt-repository ppa:remmina-ppa-team/remmina-master
    sudo apt-get update
    
  3. Install all the things:

    sudo apt-get install remmina* -y
    

Well, perhaps a reboot would've done the trick.

I removed Remmina from my machine yesterday and I shut my machine down at the end of the day. After starting it back up this morning, I installed Remmina again.

sudo apt-get install remmina remmina-plugin-vnc remmina-plugin-rdp

After this, I was able to connect to Windows machines again; no complaints about missing plug-ins.


While this has worked for me for now, I won't accept my own answer, since it just happened to work; I have no clue why.

  • simply sudo apt-get install remmina-plugin-rdp helped me too (Mint Xenial) – vladkras Jul 20 '17 at 8:46

The Remmina developers now maintain a snap in the snap store. You can install the app either from Ubuntu Software (on Ubuntu 16.04 and above) and via the command line (from Ubuntu 14.04).

Installing from the snap store has the benefit that the upstream Remmina developers keep the snap up to date.

Installing from Ubuntu Software

Remmina in the Ubuntu Software Store

Installing from the Terminal

If you're on Ubuntu 14.04, you may not have snapd installed, which provides support for installing snaps. snapd can be installed easily via apt.

sudo apt-get update sudo apt-get install snapd You may need to logout / back in to ensure icons appear in the launcher for snap installed applications.

Installing Remmina is then simply:

sudo snap install remmina

  • How does this answer my question? The problem was not installing Remmina, the problem was that it did not shut down all processes. – SQB Apr 30 at 16:50

protected by Community Jan 23 at 9:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.