2

I've just installed ubuntu 16.04 and installed ubuntu mate. I've added other keyboard layouts via language indicator on the right upper panel. The indicator shows different layouts, I can switch between them using the applet or the shortcut super+space, just the layout doesn't change - it's the layout I've choosen during the installation. When I log in on unity, I'm able to switch between different keyboard layouts (although I had to add them to unity desktop separately).

In mate desktop I've added also new layouts to keyboard preferences (in system preferences. Still nothing happens when I'm switching between different layouts.

UPDATE

I've run gsettings get org.mate.peripherals-keyboard-xkb.kbd layouts

The terminal output is: ['pl', 'ara', 'fr']

UPDATE

top panel screenshot

  • 1
    The update shows that you successfully added multiple layouts in MATE. I'm not able to reproduce the problem on a clean Ubuntu MATE install; the layout does change when I switch between them. Possibly the existence of the Ubuntu layout settings in your $HOME confuses MATE somehow. If it's Ubuntu MATE you want to use, you may be better off to install Ubuntu MATE via the Ubuntu MATE ISO. – Gunnar Hjalmarsson Oct 12 '16 at 19:29
  • Can you give us a small screenshot of the top panel's relevant part? – Anwar Oct 15 '16 at 13:13
  • @Anwar - the screenshot is in the second update. – maria Oct 18 '16 at 11:07
  • 1
    I have the same problem on the same scenario. My guess is that only the Ubuntu indicator is "registered" to change the keyboard layout, while the MATE applet is not. However at the moment I do not know how to "fix" this. – Phoenix87 May 24 '17 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.