1

Recently, I install Xubuntu 16.04 on my Acer Aspire E1-570G. It wasn't going to suspend when I close the lid, so I used a little trick by uncommenting HandleLidSwitchDocked=suspend on /etc/systemd/logind.conf and it worked properly (when opening and closing lid, everything was OK).

Yesterday, I upgraded my Xubuntu to 16.04.1 by using sudo apt-get update && sudo apt-get upgrade.

My devices suspends when I close its lid, but when I open it back, I just see a command line cursor blinking and after a few seconds it stops blinking and nothing more comes out, have to restart it by ALT+PRT SC and type REISUB.

What should I do to fix this problem?

P.S.: sorry for too much details :)

  • I tried the kernel update, didn't work. – user606569 Oct 13 '16 at 20:41
1

Try upgrading your kernel. Seemed to do the trick for me.

Second answer here: With Ubuntu 16.04 laptop doesn't suspend when lid is closed

  • I just started upgrading my kernel from 4.4.8 to 4.8.1 . About the second answer, I followed the instructions there and that's my problem now (read my question again). – Ehsaan Oct 11 '16 at 9:44
  • Wasn't all that awake when I posted that. Updating the kernel was the second answer in that post, which is why I suggested it. Thought you had already updated it and I just read it wrong, which is why I deleted the answer. Glad you've figured it out in spite of my grogginess. – MSchu Oct 11 '16 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.