2

I have an HP EliteBook 820 G3 Laptop that I use with an HP docking station and 2 x Display Port monitors.

I have had endless issues with the Intel Graphics drivers for this chipset (Skylake) since I first installed Ubuntu so I suspect this could be graphics related.

Description of the problem

Whenever I step away from my laptop I lock it (Super + L) and 3/5 times the system will freeze completely. All 3 monitors will blink and then the primary monitor will turn back on and display the last frame interspersed with grey lines. If there is any music playing at this point it will get stuck in a 1 second loop.

When this happens I cannot get to console prompt, I cannot use SysRq + REISUB, the system is completely frozen.

(For info - I know REISUB works because I can use it with a running kernel and I have enabled full SysRq features)

What I've tried so far...

As I've said already, I've had endless graphics issues so far with this laptop - everything is fine until I connect to the dock with 2 x Display Port monitors, then it all goes to hell. The lockup described above has been around since day 1 but with varying frequency.

Early on I had to upgrade to an Intel Nightly kernel after an Ubuntu kernel update broke my setup. I went back to Ubuntu mainline (4.4.0.36) after the issue was fixed. I get a lot of screen flicker though so I switched to the "recommended" Graphics Stack for Intel.
I used the Ubuntu 4.7.2 Kernel and built the rest of the components manually. This works quite well - there is no annoying flicker but the full system lockup seems worse. I tried the 4.8 Kernel as well but there are regressions in i915 which make the flicker worse.

Google this error for more info on the flicker:

[drm:gen8_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun

What to try next?

This is where I need help... After a lockup and reboot I have checked

  • /var/logs/kern.log
  • /var/logs/Xorg.0.log
  • /var/crash

and I cannot see anything of value in there. It's like the system was running and then it wasn't.

Is there additional debug I can enable and how can I do this?

Logs

Please let me know if there are other logs I can provide that may help...

2

Answering my own question so I can close this issue....

After months of trying various things the best solution was to upgrade to Ubuntu 16.10. There are a lot of Intel specific updates in the newer kernels and this seems to have resolved my issue completely.

Since January 2017 I have probably experienced only 1 full system lockup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.