I'm using network-manager to connect to VPN. I fill the username and password and check to remember password. But when I'm trying to connect next time it does not remember the username - only username, password is prefilled. It's quite annoying and unfortunately I have no idea how to fix...

Thanks for answers.

(Ubuntu 16.04)

  • Which VPN type?
    – thaller
    Oct 12 '16 at 22:27
  • I'm not sure what is the correct answer to your question. What type do you mean? I'm using it instead of the Cisco AnyConnect VPN client.
    – Fiisha
    Oct 13 '16 at 7:50

So you are using openconnect, with the corresponding NetworkManager plugin.

Sounds like https://bugzilla.redhat.com/show_bug.cgi?id=1332491

It's a bug in libnm. Fixed upstream.

  • Thanks for answer. Just another question. Am I enable to test the fix on my Ubuntu? Or I have to wait till the fix will pass to the Ubuntu repo?
    – Fiisha
    Oct 14 '16 at 5:45
  • I have the same issue on Ubuntu 20.04 with everything updated. Any idea why?
    – Kvothe
    Feb 17 at 15:50

I ran

    sudo apt-get -y dist-upgrade

which pushed me up to 16.04.2, and it solved the problem you describe.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.