1

I have a problem with my Lenovo x230i Thinkpad. Everytime I login or power on the system, the backlight turns on and I have to use Fn + space manually to turn it off. Its a little irritating to do it everytime manually. So, I want to completely disable the backlight option but I am clueless about how to do it in Ubuntu 14.04. I checked the power manager and the keyboard options, but there is no such option to completely turn it off. Can anybody please suggest me a fix to this problem?

1

You should make a script wich would press those keys automatically after startup.

To do that you would need to create an empty document and write down the following:

#!/bin/bash
xdotool key fn+space

Save it as .sh ( i.e. Keyboard Backlight Off.sh ) and move the resultant document into the init directory, wich is the usual process starter. The exact name of such drectory may change, so search for something like:

/etc/init.d

or

/etc/rc1.d (the number after 'rc' may change)

or

/etc/rc.local

I recommend you to try add it to the last option --> /etc/rc.localas it's usually better to add your own scripts in there.

Hope it works and post the feedback.

If you want to look up more information about it here you have some links:

Xdotool

Xdotool on Ubuntu Manpage

  • 1
    Before trying this, I want to inform you something about this problem. This was never the case earlier until the system stopped responding for a while which lead me to pressing random keys to see if it would respond. Since then the problem persists. It isn't a problem actually but more of a distraction – crypto Oct 11 '16 at 11:36
  • If you want to disable it without any kind of script, there must be a way by finding the '.conf' that controlls the backlight of the keyboard and set its value to "0". Although those files are found on different ways depending on the brand, model, series, etc. You could do a search on your system files on your file manager searching smth like "kdb backlight", "backlight" or similar. In case you find those post it. – M. Becerra Oct 11 '16 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.