I have a roughly month-old installation of Ubuntu 16.04 on a Dell XPS 13. Until today, my speakers and headphones worked more or less flawlessly. A single device appeared in the "Play sound through" list in the "Sound Settings" dialog (regrettably, I don't remember what it was called).

Today, I opened up an old Audacity project and noticed that the sound was coming through the built-in speakers, even though I had headphones plugged in. I played around in "Sound Settings" a little, and in particular I tried selecting the various HDMI output settings in the "Mode" dropdown, instead of the blank line that was selected by default.

Now, no devices appear in the "Play sound through" list, even though aplay -l lists the same devices it always has:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


aplay /usr/share/sounds/alsa/Front_Center.wav

gives no audio output. However, running

aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav

gives the expected output—through my headphones if they're plugged in, and through the built-in speakers otherwise.

The settings in alsamixer look fine, although I noticed one strange thing: at some point, the master volume changed itself from 66 (where I set it last) to 41, for no apparent reason.

I've re-installed alsa-base and pulseaudio, rebooted several times, and done a cold reboot, to no avail. I just want everything back the way it was last week...


For me, the problem appears to have been corrupted configuration files in my home directory. I followed just the first part of the instructions from this sound troubleshooting page -- in particular steps 1A and 1B -- and that appeared to clear the problem for me. At this time, my sound is working as expected again.

I'd suggest the following, basically step 1B:

sudo killall pulseaudio
rm -r ~/.config/pulse/*
rm -r ~/.pulse*
sudo shutdown -h now

Let the computer sit quiet for 10 seconds or so, and then reboot.

I would not recommend following the remainder of the procedure on that page, unless you really know what you're doing, or are prepared to have to reinstall your system from scratch. It's very heavy handed.

  • 2
    "Let the computer sit quiet for 10 seconds or so, and then reboot." That makes nothing, actually... – Fran Marzoa Sep 5 '17 at 11:59
  • @FranMarzoa I report what worked for me. I did try several times doing a warm boot sudo shutdown -r now and it failed every time. It wasn't until I did the full stop, and waited, that it finally worked. Why? I could only guess. – EdwinW Jun 17 '18 at 12:11
  • This had no effect for me. – Cerin Jul 25 '18 at 14:26
  • @Cerin I am sorry to hear that. Your situation must be quite different from mine. I'd suggest going to the page I referenced and seeing if there's anything else that you would be comfortable with doing. – EdwinW Jul 25 '18 at 14:58
  • 1
    This works. The case of mine: this morning my sound card device suddenly disappeared from KDE Sound Tray (I use neon, based on Ubuntu 16.04). Invoking first command above brings it back. – Ade Malsasa Akbar Dec 19 '18 at 4:20

This command restart all alsamixer config :

alsactl restore

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.