When I open Startup Disk Creator, I see that only there is only 8kB of free space in my USB drive even though I deleted everything in it. When I click on Erase Disk, I then get this error

org.freedesktop.DBus.Python.GLib.Error: Traceback (most recent call last):
 File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
retval = candidate_method(self, *args, **keywords)
 File "/usr/share/usb-creator/usb-creator-helper", line 274, in Format
part.call_set_flags_sync(boot_dos_flag, no_options, None)
GLib.Error: udisks-error-quark: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error setting partition flags on /dev/sdb2: Command-line `parted --script "/dev/sdb" "set 2 boot off"' exited with non-zero exit status 1: Warning: The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes.

I then attempted to restore the disk image as explained here: Unknown ERROR from Startup Disk Creator

I then entered this in the prompt: dd if=/dev/zero of=/dev/sdb. I then re-tried the Startup Disk Creator and restoring the disk image, but I still get errors

When I try gparted, it gives this warning as soon as it opens:

The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes

When I then right-click on the partition and click new, it says

No partition table found on device /dev/sdb
A partition table is required before partitions can be added.
To create a new partition table choose the menu item:
Device --> Create Partition Table.

EDIT: If I click ignore, I see 4 partitions:

/dev/sdb1, File System: unknown, label: Ubuntu-Server
unallocated, File System: unallocated
/dev/sdb2, File System: fat16, Mount Point: /media/Ubuntu-Server
unallocated, File System: unallocated

How do I fix this?

  • Does this help? Unable to delete usb drive partitions block size error
    – TheOdd
    Oct 11, 2016 at 3:04
  • I click the Ignore button when using GParted and it complains about the block size. From there I'm stilll able to delete/create new partitions on USB's
    – GrannySez
    Oct 11, 2016 at 3:56
  • @owen, no that link didn't help. I just typed sudo dd if=/dev/zero of=/dev/sdd bs=2048 count=32 and tried Startup Disk Creator again, and got the same error Oct 11, 2016 at 4:19
  • @grannzsez, see my EDIT in the OP Oct 11, 2016 at 4:22
  • Partition is unformatted!...open gparted select usb from drop down menu....delete the partitions and create new one primary. Partition with ntfs format..let me know further..(select rebuild MBR option first...to recreate MBR table)
    – minigeek
    Oct 11, 2016 at 6:14


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.