1

In other words, I would like to show the output not in the external console.

When I run my hello world program:

import std.stdio;
void main ()
{
    writeln("Hello world!"); 
}

The Application Output pane shows:

[Thread debugging using libthread_db enabled] Using host libthread_db library \"/lib/x86_64-linux-gnu/libthread_db.so.1\". [Inferior 1 (process 17025) exited normally]

Instead of the "Hello world!".

Some terminal window pops up for a fraction of a second, showing the "Hello world!" message, but then it disappears.

I tried to unset the "Run on external console" checkbox in the project options, but this doesn't seem to have any effect.

I tried to crawl through all the settings, but I did not find anything that would help.

enter image description here

2

You may have figured this out by now, but I was having the same problems and figured I'd post for anyone else who might come looking.

Unchecking the "Run on external console" option worked for me, but as the Application Output window seems to be auto-hidden by default, I had to open it by clicking or hovering over " ▶ Application Output" in the bottom right corner. Once open, running the project again, e.g. with F5, will close the output box. To keep it open, click on the little "Dock" button next to the close button.

See image below for a screenshot.

this image

1

Unchecking "run on external console" changed on the 7.6.9 version (preview).

You can find it in that way: [Menu[1]

Dailog

After execution, the application Output will appear. For the next runs you can recall it, clicking on the button of the bottom bar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.