4

I have a fresh install of ubuntu 16.04.1 (only installed today) and oddly enough I have no problems with NVIDIA drivers on my system however when switching to Intel I get a black screen.

Most of the posts I have seen are about Nvidia drivers not working but since I am only using linux for work and some video playback I dont really need the nvidia card to be working I only need Intel graphics so I can save a bit of battery power too.

My system is an Inspiron 15 7559 2016 model with HD570 Intel graphics and a GPU of 960m. As I said I have no problem with Nvidia but for some reason when running

sudo prime-select intel 
sudo reboot

I get a black screen after the boot up process. If I add

nomodeset

to the kernel options I get it to start fine but without any options for the graphics (i.e. scaling doesnt work, which is essential on a 4k screen or else everything is really really small).

I have been through a bunch of posts here and on other forums but they all relate to the nvidia drivers not working rather than intel.

I installed the NVidia and Intel drivers through the "Additional Software" tab (both are enabled; intel microcode and Nvidia) and directly after installing prime-select query returns "Intel" but after a reboot I get a blank screen unless I change back to nvidia.

I have also tried to access TTY (to see if I can find some errors from dmesg) when faced with the black screen but there is no output, I have to hold down the power button and do a hard shutdown.

Laptop specs are available here:

http://www.dell.com/en-us/shop/productdetails/inspiron-15-7559-laptop

Its the last one on the right of the selection.

Ofcourse I could keep it running in Nvidia but then my battery drains really fast (max 2 hours with light usage). On Windows it runs normally and gives me hours of battery life (more than 4 usually).

Furthermore in Nvidia I see some screen distortion when coming out of sleep mode.

I previously had elementary OS 0.4 Loki installed (yesterday) but after no luck with that I thought maybe there was something not supported by that particular distro so I went for a clean Ubuntu installation.

I am running on kernel 4.4 and what I have seen online this is supposed to fix the issue? (I maybe mistaken). I am still a novice at linux so if there is any required logs, etc. that are required please let me know I will update my post.

UPDATE

Upgrading to 4.5 kernel did not help I am currently using the Intel linux graphics update tool and will update if that works.

2

I managed to get it working after many many ours. I initially wanted to install Elementary OS but I first wanted to get it working on a clean Ubuntu 16.04 install and then try the same steps on Elementary.

Heres how I did it.

  • Disable Secure Boot
  • Fresh install Ubuntu/eOS (requires nomodeset kernel parameter in boot options)
  • Download updates during installation
  • After the reboot you should be able to boot in without "nomodeset" added in the kernel params.

For Ubuntu

  • Install intel microcode from proprietary drivers and reboot
  • Install Nvidia drivers from proprietary drivers and reboot
  • Open up terminal and enter sudo prime-select query which should return nvidia which ofcourse is good as it means the nvidia drivers are working but not ideal for battery life
  • Enter in terminal sudo prime-select intel and press enter
  • Instead of log out/in, reboot the entire machine and go into the bios and re-enable Secure Boot
  • Machine should boot normally and now sudo prime-select query shoukd return intel

For eOS (Elementary OS 0.4 Loki)

  • On a clean eOS install first install the Nvidia drivers (i am using 361.42) so open up a terminal and sudo apt-get install nvidia-361
  • Reboot the machine and verify the drivers for Nvidia loaded correctly with sudo prime-select query (nomodeset should no longer be required in your kernel options)
  • Go to Intel Linux Graphics Firmware and download Kabylake DMC and Skylake DMC and GUC drivers from their links on the page.
  • Install it by following the instructions on the page:

For GUC Firmware File

$ tar xf _guc_ver_tar.bz2

$ cd _guc_ver_

$ sudo bash ./install.sh --install

For DMC Firmware File

$ tar xf _dcm_ver_tar.bz2

$ cd 'product code_dcm_ver'api version'_'min version'

$ sudo sh install.sh

  • Once installed reboot once again and verify the system is loading without nomodeset param and current selection is on nvidia with sudo prime-select query

  • If all is well you can run sudo prime-select intel and reboot (last reboot I swear!

  • Finally during the restart hit F2 for the bios and re-enable Secure Boot

After this point you should be able to load up the OS without any added kernel parameter and sudo prime-select query should return intel.

For any additional troubleshooting if you are still getting a blackscreen after the splash screen add the following to `/etc/modprobe.d/blacklist.conf'

blacklist amd76x_edac

blacklist vga16fb

blacklist nouveau

blacklist rivafb

blacklist nvidiafb

blacklist rivatv

and then run sudo update-initramfs -u and reboot once again.

0

The problem w/ secure mode is that it prohibits to load the nvidia module later on, when one wants to use it for CUDA application. This is how I went around it: 1. Disable secure mode in BIOS. 2. Disable all nvidia modules in blacklist.conf (dont forget to run depmod & update-initramfs after it) 3. The nvidia modules dont load at startup, making the intel module load for display, but you can load them manually with modprobe.

This method allows CUDA to run, while not interfering w/ display.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.