So my laptop won't connect to wifi anymore. Running 14.04 on a Lenovo yoga 2 13. Here's what's true:

It won't connect to the network at the cafe, or the one at my house. I enter the password and it just doesn't connect. It won't connect to my mobile hotspot wirelessly, but it does work when I plug the phone in. It will connect to the xfinitywifi network, but won't even load the login page.

I've tried playing around in the network manager, and have also tried a few basic terminal commands like network manager restart, but I don't know jack about terminal.

Any suggestions would be appreciated. And yes, I've already looked at similar posts and none of those solutions seem to be working for me.


Wireless card is Intel 7270, name is wlan0


I had a similar problem and installed WICD. In the terminal, enter these commands and your password.

sudo apt-get install wicd 
sudo service network-manager stop
sudo killall wpa_supplicant

This installs WICD and temporarely stops the network manager. Worked for me, can't give you much help beyond that, though.

If it does work, you can go ahead and purge the network manager (delete NM and it's dependencies)

sudo apt-get remove --purge network-manager network-manager-gnome 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.