2

So, my headset is not properly recognized by my laptop.

I have been fiddling with it for a couple of days and have tried several online solutions, none of them work for me.

Problem: My headset jack does not recognize my headset and microphone on it's own. I can manually change the output channel so I can at least get some sound out of the jack. But the microphone is not working and not recognized. While the sound is working after changing it manually, it is still displayed as 'unplugged'. I can not get my microphone to work. The internal mic does not work either. The internal mic pretends to get some sound, but I can't record or stream anything either.

I have fiddled around with alsamixer. Nothing muted, changed setting all over the place without any real change. I have installed pavucontrol, pulseaudio, audacity(for the codecs), updated dkms, and the sound did not get better - in fact, I got less channels to use, most of which do not work, on certain setting I didn't get any sound at all, not even out of the internal speakers. Some setting were just terrible low. Reinstalled ubuntu-desktop several times. Nothing seems to work. I have also tried changing some details in the .conf files, but they didn't change the sound a single bit. Also had a look at hdajackretask. Not quite sure of its specifics, though.

I did try a friend's USB headset, it works perfectly, as far as I could tell.

My card is the HDA Intel PCH, my driver is the Realtek ALC 256. The laptop is an ASUS X555U with Skylake. Ubuntu 16.04.

What else can I do? I am fine with changing the channel for the headset manually, but microphone not working is kind of a bummer.

Edit: If it's any help, here's the alsa info: http://www.alsa-project.org/db/?f=c6ef73aae969f1da4347154e2977d49711a81e78

Edit: I have fixed the detection for the headphones by adding the proper model to /etc/modprobe.d/alsa-base.conf in my case that was either options snd-hda-intel model=headset-mode or options snd-hda-intel model=headset-mic (both work just fine). It now switches between speakers and headphones on plugging in/out automatically.

However, neither the internal nor the headphone microphone works.

Edit2: There is a workaround in place for this, only works till reboot.See here for more: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1596381 Seems they are on it and since this is good enough for me, I'd say this is solved.

0

There is a workaround for the Asus X555U with the Realtek ALC256 place for this, only works till reboot.

sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x5003
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x6003
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x5200
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x6200
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x503f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x603f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_POWER_STATE 0
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_POWER_STATE 0

See here for more: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1596381

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.