1

I want to install my Evermore Integrate Office 2007 from my cd. Followed the instructions exactly, but hit different problems. Previously I installed it like that on an Acer Aspire One Netbook.

Linux Installation: Method One: Log on as root and insert the CD installation disk in the CD or DVD ROM drive, run from the EIOffice CD and the EIOffice Install Wizard will begin. Follow the On-Screen install procedure.

Click on setup and I get this error;

Invalid url: '/media/chris/EIO2007/Linux/setup' given, exiting
No ':' in the uri

Method Two: Log on as root and Insert the CD installation disk in the CD or DVD ROM drive. Run the terminal window and input "cd /mnt/cdrom/Linux", press Enter and then input "./setup", the EIOffice Install Wizard will begin. Follow the On-Screen install procedure.

Sudo'd into root. In my case ~#: cd /media/chris/EIO2007/Linux. Command "setup" gets error command not found, ./setup gets error Permission denied.

Tried cd /media/chris/EIO2007 then cp /media/chris/EIO2007/Linux /usr/EIO2007 gets cp: omitting directory /media/chris/EIO207/Linux' (read-only disc?)

chmod 1777 not working as expected since it is a read-only disc.

I can read all the files in command line after cd /media/chris/EIO2007/Linux and ls -l as I see them in the File Manager, so I don't understand the error in the first method.

Thought of sudo apt install, but there is no identifiable file name. The /Linux/assocaiate (sic) folder has three directories; Fedora, Impi and Suse. Oh yes, there is a "dispose.jar" file but I do not understand/fear to try it without at least some knowledge of it.

Wit's end. Any ideas welcome, thanks.

11
  • 'chmod 1777 not working' - did you mean 0777? The best command to give executable permission is `chmod +x FILES'. Anyway, it's not gonna work in a read-only path. Commented Oct 9, 2016 at 13:51
  • Another question -- why are you using a proprietary (according to my knowledge) office package when you have LibreOffice? Commented Oct 9, 2016 at 13:54
  • What's the output of ls -l /media/chris/EIO2007/Linux/setup and grep -Fe /media/chris/EIO2007 /proc/mounts? Commented Oct 9, 2016 at 14:11
  • 1
    This is 10 year old software. Is it still supported on current linux distributions? Libreoffice is probably a better alternative. It is stable as long as you work in the native formats and export to MSO when needed.
    – Bruni
    Commented Oct 9, 2016 at 14:39
  • David, Output to the first question is this; -r-------- 1 chris chris 23333 Oct 19 2006 /media/chris/EIO2007/Linux/setup. Output to the grep is/dev/sr0 /media/chris/EIO2007 iso9660 ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500 0 0.
    – Christo
    Commented Oct 9, 2016 at 18:07

1 Answer 1

1

Execution permission issue always happens in GNU/Linux when you try to install something from CD-ROM. This is probably because the CD-ROM filesystem is not designed to handle Unix execution permissions.

The best thing you can do here is to copy the content of the disk to a local folder, give files appropriate permissions and run the setup.

If the problem with colon (:) exists because the setup program expects it, you can simply fake it by renaming the parent directory with a colon in it (I'm afraid I'm not sure about it -- it could have been an issue with Nautilus also; anyway, try).

19
  • I tried that as I said in the second paragraph under Method 2. Ubuntu will NOT copy the file on disc to an internal folder. If I have it correctly the parent cannot be renamed as it is on a read-only disc. OK, ta, set me to thinking. Maybe some other ideas to try.
    – Christo
    Commented Oct 9, 2016 at 19:02
  • @David, The output to the grep command gave me the idea on Nanda's comment about permissions. Did cp /dev/sr0 /usr/Yozo. Disc spun up flawlessly. Opened up /usr/Yozo and there she was! sr0, but I can't open it. OK, Properties, sure enough; 256.6MB. Just about the right size for both Windows and Linux Files.
    – Christo
    Commented Oct 9, 2016 at 19:18
  • @Christo, please try other methods to copy the disc. You can create an ISO image of the disc using Brasero, open it with Archive Manager (not mounter), extract the files and do the permissions thing. Try that and let me know where it leads us to. Commented Oct 10, 2016 at 4:22
  • I did think of that, but I did not know about Brasero. I incidentally tried to open the sr0 file in the file manager with several options, but no go. In the same session I clicked on another file I had downloaded in /tmp/something. No external disc near it, same (:) error. Trying to find it again not successful. Your interest much appreciated. Will do.
    – Christo
    Commented Oct 10, 2016 at 10:21
  • @Christo, opening sr0 is not a solution. It is just a raw binary stream. you have to either mount it (which is what automatically happens when we 'open' a CD) or convert it to a useful format. Mere mounting has proved useless in your case, that's why I suggest the second choice: creating an ISO image of the disk with Brasero and trying to extract files from it. I'm happy to learn that you've got the idea and started working on it. Please let me know what happens. Commented Oct 11, 2016 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .