6

At some point, I've added a remote mount to a Owncloud installation. I've since reinstalled Owncloud, so the original remote has the wrong login details. Every time I login to my computer, whatever is mounting the remote tries to login to Owncloud with the original password, but fails to do so. However, Owncloud is working perfectly well. It syncs succesfully and has no problems logging in. The problem relates only to whatever remote mount is visible in Nautilus.

I have no idea what I used to mount the remote and can't figure out how to edit or remove the mount.

The remote shows up in my Nautilus menu (pic below), but is not listed with df, presumably because it is not mounted. Nautilus can't edit the mount and trying to mount it by clicking just shows a text box telling me that the login details are wrong.

Screenshot of Nautilus

I can see the remote with gvfs-mount -l, but I can't figure out where the configs for the mounts are stored and how to edit them.

Volume(0): XXX@XXXX.com
  Type: GProxyVolume (GProxyVolumeMonitorGoa)

The contents of my .gvfs-folder and /run/user/USER/gvfs are empty. The remote is not mounted in my fstab.

How do I edit and/or permanently remove the remote mount?

Below is the requested content of my /$HOME/.local/share/data/ownCloud/owncloud.cfg. I have sanitized it slightly by replacing my username with "usename", the actual domain with "domain.com" and removed the certificate. I have also translated the actual folder names to English.

[General]
crashReporter=true
monoIcons=true
newBigFolderSizeLimit=500
optionalDesktopNotifications=true
useNewBigFolderSizeLimit=true

[Accounts]
0\Folders\1\ignoreHiddenFiles=true
0\Folders\1\localPath=/home/username/Documents/
0\Folders\1\paused=false
0\Folders\1\targetPath=/Documents
0\Folders\2\ignoreHiddenFiles=true
0\Folders\2\localPath=/home/username/Documents/
0\Folders\2\paused=false
0\Folders\2\targetPath=/Pictures
0\authType=http
0\http_certificatePasswd=
0\http_certificatePath=
0\http_user=username
0\serverVersion=9.1.3.1
0\url=https://domain.com
0\user=username
version=2

[ActivityListHeader]
geometry=@ByteArray(\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\b\x1b\0\0\0\x5\x1\0\0\x1\0\0\0\0\0\0\0\0\0\0\0\0\x64\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\x5\0\0\0\x96\0\0\0\x1\0\0\0\0\0\0\x2\xdc\0\0\0\x1\0\0\0\0\0\0\0\x64\0\0\0\x1\0\0\0\0\0\0\x3\xe1\0\0\0\x1\0\0\0\0\0\0\0\x64\0\0\0\x1\0\0\0\0\0\0\x3\xe8\0)

[BWLimit]
downloadLimit=80
uploadLimit=10
useDownloadLimit=0
useUploadLimit=0

[Settings]
geometry="@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\x1+\0\0\0\x93\0\0\x6\x46\0\0\x3q\0\0\x1,\0\0\0\xaf\0\0\x6\x45\0\0\x3p\0\0\0\0\0\0\0\0\a\x80)"

[ownCloud]
General\CaCertificates="[Certificate removed]"
authType=http
http_certificatePasswd=
http_certificatePath=
http_user=username
url=https://domain.com
user=usename
  • Anything in ~/.config/gtk-3.0/bookmarks? – steeldriver Oct 10 '16 at 14:40
  • Nothing relevant. Those wouldn't try an automount either, would they? – krax Oct 12 '16 at 7:17
  • Please edit your post with the ouput of cat $HOME/.local/share/data/ownCloud/owncloud.cfg or provide a pastebin link to it. Thank you for helping us help you! – Elder Geek Oct 27 '16 at 22:19
  • Please edit your post with the content of ` /etc/davfs2/davfs2.conf.` Best guess at this point. For other ideas see this – Elder Geek Mar 27 '17 at 5:52
  • This might possibly help you remember what you did originally. That would be very useful to know in order to reverse the process. – Elder Geek Mar 27 '17 at 5:55
2

Nautilus Version 3.18 introduced integration with Google Drive and GOA (gnome-online-accounts) settings.

If you simply want to remove a GOA, Launch Online Accounts, select the account you wish to remove on the left and Click the Remove Account button in the lower-left corner of the window as shown below:

GOA

An alternative approach would be to use apt to purge the package entirely but that seems much like taking a sledgehammer to a screw.

If you want to repair your connection, read on.

By default, owncloudcmd reads the client configuration in $HOME/.local/share/data/ownCloud and uses the credentials of the GUI synchronization client. If no client is configured, or if you choose to use a different user to synchronize, you can specify the user password setting with the usual URL pattern. For example:

$ owncloudcmd / https://carla:secret@server/owncloud/remote.php/webdav/

You can open the Owncloud Sync client that has failed to connect.

errorconnecting

A right click on the icon will open the following menu.

menu

Choose Settings and Click Modify Account or Accounts depending on your version of the client on the screen similar to what is shown below.

modify account

You should be able to modify account credentials or worst case, remove and re-add the account as necessary

Sources:

https://en.wikipedia.org/wiki/GNOME_Files

https://help.gnome.org/users/gnome-help/stable/accounts-remove.html.en

https://owncloud.com/latest-gnome-ships-with-owncloud-support/

https://doc.owncloud.org/desktop/1.8/navigating.html

https://doc.owncloud.org/desktop/2.1/navigating.html

  • Thanks, but you did not answer the question that was asked but some completely different question. Deleting your answer would probably be the best solution. – krax Mar 24 '17 at 6:25
  • @krax From your question It seemed clear to me that you needed to edit the credentials to successfully mount the remote store. You have my apologies if you meant something different. Be that as it may, Just because this isn't the answer you wanted doesn't mean it's not accurate. I suggest that you review this (at least the final paragraph). I believe this answer has value to future users, is accurate and as such I will not be deleting it. In future please be so kind as to respond to requests for further information by editing your post. – Elder Geek Mar 24 '17 at 14:40
  • I think you are using the word "mount" very liberally. Owncloud doesn't mount anything by itself, so your solution would be to general sync problems -- which I don't have. My Owncloud works perfectly. But as described in my problem, I have a remote file system mount shown in Nautilus that is trying to access my Owncloud unsuccesfully. Your suggested solution does not relate to that problem. The difference seems unclear, so I will clarify my question. I have added the contents of the file you requested. Sorry, I didn't notice the request at first. – krax Mar 26 '17 at 7:23
  • @krax You have my apologies for using mount as you did in your question if for some reason that offends you, review yoru own post. Comments on your post should show up in your inbox. You can also set notification preferences on your profile page Under Edit Profile and Settings - >Preferences It is my sincere hope that this information may help you . – Elder Geek Mar 26 '17 at 13:15
  • I simply meant that you use the word in a different sense than it is usually used. I use it in my post because I mean that Nautilus is trying to mount the filesystem remotely. Your comment (and answer to my question) seems to imply that it is Owncloud that is trying to mount the folder, which is to the best of my knowledge, false. As far as I know, Owncloud doesn't mount anything. I will gladly revise my position if I am mistaken. – krax Mar 27 '17 at 14:03
0

Edit your ~/.config/goa-1.0/accounts.conf to remove WebDAV link

  • Please note that your answer is not for OP alone bu also for other site visitors so please tell us how this should be done! – George Udosen May 11 '18 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.