2

My version of ubuntu mate is 16.04. Wireless adaptor : Ralink RT5390

The Wifi suddenly stopped working one fine day and the network panel would say "device not ready". I tried solutions given online, but nothing worked for me. Instead the wifi row from network panel is gone.

Output of lshw -class network:

WARNING: you should run this program as super-user.
  *-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eno1
       version: 06
       serial: 10:1f:74:0a:39:f2
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:34 ioport:4000(size=256) memory:c0404000-c0404fff memory:c0400000-c0403fff
  *-network UNCLAIMED
       description: Network controller
       product: RT5390 [802.11 b/g/n 1T1R G-band PCI Express Single Chip]
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:0d:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: latency=0
       resources: memory:c4500000-c450ffff
  *-network
       description: Ethernet interface
       physical id: 2
       logical name: enp25s0u1
       serial: ca:3c:02:e3:3a:7b
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.136 link=yes multicast=yes
WARNING: output may be incomplete or inaccurate, you should run this program as super-user. 

1 Answer 1

0

See section " PCI (internal) wireless adapter " in https://help.ubuntu.com/stable/ubuntu-help/net-wireless-troubleshooting-hardware-check.html#pci

#

https://help.ubuntu.com/stable/ubuntu-help/net-wireless.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .