I am running Xubuntu 16.04 on my Acer Aspire E5-573G laptop, which apparently uses Optimus and doesn't have a BIOS option to switch between integrated and discreet graphics. I followed this answer to try to get my NVIDIA GeForce 940M to work using nvidia-364. While I can use my card by executing # prime-select nvidia and relogging, Xorg crashes upon the next logout, reboot, or shutdown, even if I first execute # prime-select intel. Therefore, I'd like to use my card only through optirun (or primusrun; I haven't been able to find how the two differ).

The first time I try to use optirun, I receive the following error message:

$ optirun glxgears
Xlib:  extension "GLX" missing on display ":8".

All subsequent times, I receive these:

$ optirun glxgears
[   61.760218] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) 

[   61.760244] [ERROR]Aborting because fallback start is disabled.

I haven't been able to find any leads on the first error message, but as for the second set, I found this answer, which I followed only to discover my /etc/bumblebee/xorg.conf.nvidia already had the correct line:

$ lspci|grep NVIDIA
04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)

$ grep BusID /etc/bumblebee/xorg.conf.nvidia 
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
    BusID "PCI:04:00:0"

I also found a relevant thread, but adding acpi=force to the boot parameters did not solve the problem.

I've also tried nvidia-361; the system would not boot with acpi=force but otherwise exhibited the same issues as nvidia-364, nvidia-367, and nvidia-370 (all of which I've tried). Nouveau also emits the same error messages. For what it's worth, I've noticed leaving a 3D application running while not the focused window eventually crashes Xorg, regardless of whether it's using integrated or discreet graphics or even of if I have Bumblebee installed.

I realize NVIDIA provides terrible support for Optimus on Linux, but any help getting my card working reasonably well would be much appreciated. I know I could just uninstall Bumblebee and use integrated graphics, but that doesn't answer this question.

  • I am facing similar issues. I have a Clevo laptop that does not have the ability to switch between onboard and discrete graphics. I am struggling to get the display drivers working properly. One suggestion that I can give is to include nouveau.modeset=0 in the grub, thereby disabling the nouveau drivers. That should at least take care of the frequent crashes and lockups. Oct 12, 2016 at 21:57
  • any luck so far? Apr 16, 2017 at 23:58
  • Oh, wow; it's been awhile. So, yes, my system is working; however, I don't exactly know why. I'm currently just using the NVIDIA driver and switch between integrated and discreet with PRIME. (I almost exclusively use integrated graphics to save power.) There are a few glitches with discreet (e.g. not being able to shut down while charging), but, for the most part, it works. I'll have to test trying to get a fresh install to work when I have some time in a few weeks.
    – Matthew
    Apr 29, 2017 at 2:52


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.