I have a D-link wireless router and an Adsl 5MB/s connection. The router have a Qnap box and a boxee box connected with 100/10 network cable, also we got My wife PC (running win7) my PC (dual boot win7 / Ubuntu 11.10), my laptop (dual boot win7 / Ubuntu 11.10) and my mobile (android 2.3).

I've used speed test to monetize my internet download speed, I've run these tests on my PC, my wife PC and my cellphone (They've got an app for that).

Beside my PC, all the devices showed a ~ 5MB/s download stream while my PC showed things like 0.1MB/s <> 0.8MB/s. If I disconnected the WiFi connection and than reconnected - the speed test showed a 5MB/s download speed for few tests, but after a minute or so - the connection dropped down to the under 1Mb/s limit.

Doing the same tests on my PC using windows 7 showed no such problems and the connection was steady at 5MB/s.

I've searched around askubuntu and tried several things (turned off ipv6 and power management ) but with no success.


$ sudo lshw -C network

       description: Wireless interface
       product: RT2500 802.11g
       vendor: Ralink corp.
       physical id: 7
       bus info: pci@0000:01:07.0
       logical name: wlan0
       version: 01
       serial: 00:0e:2e:57:80:39
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2500pci driverversion=3.0.0-12-generic firmware=N/A ip= latency=64 link=yes multicast=yes wireless=IEEE 802.11bg
       resources: irq:18 memory:f9ffe000-f9ffffff
  • 1
    Does the problem happen when downloading a torrent as well? – Exeleration-G Nov 28 '11 at 16:34
  • or from a stable source that provides constant speed – Book Of Zeus Nov 28 '11 at 23:29
  • Yes, I've tried to download a 500MB file from my ISP server and got a 0.8MB/s download rate – Nitzan Brumer Nov 29 '11 at 18:01

This is apparently a known kernel bug. The launchpad bug report is here, and there is a workaround listed in comment 161 which may work for you.

  • I've already set the power management to off, did not work – Nitzan Brumer Dec 2 '11 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.